Error after create cascade select


I created a cascade select with 1521 records. It was created fine but when I preview the form it just keeps on “loading” and shows this error “There has been a problem trying to replace ${region} with the XPath to the survey element named ‘region’. There is no survey element with this name.”

What am I missing here?

Any help appreciated. Thanks.

@techremote.opc, you could validate your XLSForm through this online validator to identify the syntax issues. But looking at your error message, I see that you have used the region in the survey sheet, which is not reflected in the choices sheet.

You should be able to understand your issue more by following these community posts discussed previously.

Thanks for the reply, I set up the questionnaire in Kobotoolbox’s Form Builder. Sharing the cascade select sheet I created for reference. PSGC Kobo Cascade Select Regions to Municipalities - Google Sheets

Tried the online validator and it didn’t report the same error, but different. Screenshot by Lightshot

I was able to figure out the error.

1 Like

@techremote.opc, could you also share the solution? Your solution should benefit the entire community having similar issues.


I renamed the question names and referenced them properly in the “Choice Filter” field.



1 Like