Error: Data server did not accept data. Contact the survey administrator please. (400)

I am getting this error after trying to submit a form. The form had already been submitted to the server, I did an edit to one of the records and tried to resubmit it but got this error.

I am using the kobo humanitarian server (ee).

Please assist.


Welcome back to the community, @dkuria! Could you also let the community know the question type you tried to edit?

Not sure what you mean by question type, but it is a select_one type of question.

I can give you access to the data to have a look if that is okay.

1 Like

@dkuria, would you mind sharing with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Project name
  • Server

Note: You could share with me a private message as outlined in the post discussed previously:

Hi @dkuria, I have tested editing a submission and it worked without issue so this may have been an isolated incident. Can you please share the id of the submission you tried editing that failed so I can see if it’s perhaps related to that specific one.

1 Like

Hello @Josh, as mentioned to @Kal_Lam not all records are affected, just some of them. You can try the following _id


They were all submitted on the same day. It seems it only affects these ones. I haven’t had a chance to check the whole dataset.

1 Like

Hi @dkuria, it looks like the issue was that these submissions were deleted but just not reflecting as such in the UI. I have resynced your data and those submissions are no longer visible and aren’t reflected in the database:

>>> x = XForm.objects.get(id_string='aTUee6RADPd7osgzwtbQYJ')
>>> ids = [314864948,314864942,314864936,314864839,314864820,314864811,314864791,314864766,314864752]
>>> x.instances.filter(id__in=ids)
<QuerySet []>

(The <QuerySet[]> response indicates that the records are not present in the database)

1 Like

Hi @Kal_Lam, i face the same issue while i update information in the database.

Hello, i also have the same error, but i did not erase or edit anything. It is a full day of data so i hope i did not lose it. could anyone help to get it submitted? I am not on the humanitarian server.

Somehow over the weekend i could update the form and no data was lost, however on the survey on Monday some of my groups in the form were not dropping down. After the form was redeployed redeployed, it was working again. however today I’m struggling with the same error. is it possible the form has to many pictures? Do i need to break down this form, where I make different forms for the individual groups?

Thank you,

These guys @Vravmo00 on Instagram are the best in the business! Very responsive! They notated my problems & quickly came up with a gameplan to make my problems go away! I’m so glad I went to them instead of trying to figure out how to do this on my owm.