Error Getting Form List - Charset returned Not Text/XML

1. What is the problem? Be very detailed.
I cannot load forms on my private server of Kobo onto my Android device. When entering the server settings, this error

Server settings:
username: my username
password: my password
Form list path: /forms

The URL I see on a web browser is

The error I get is:

Error Getting Form List
Form listing failed. ContentType: text/html; charset=utf-8 returned from: (the URL I typed above – as a new user I cannot post more than 2 links…) is not text/xml. This is often caused a network proxy. Do you need to login to your network?.

2. What app or server are you using and on what device and operating system? Include version numbers.

KoBoCollect v1.14.0a

Android itel A14 Android version 8.1.0

3. What you have you tried to fix the problem?
I’ve tried modifying the URL to include kc. as a preface, but I get a different error that seems to mean it’s not finding the server

I’ve tried removing the # but I get a 404 error. I’ve tried moving the # into the Form list path field, but I get the same error as above (not text/xml)

4. What steps can we take to reproduce the problem?

It always happens

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Typically the URL is of the form:

But because you are running your own server you may have configured things differently… I might suggest running some simple curl commands to check your setup [curl is almost a must-have when testing your own web servers…]. There’s some useful info in this thread

1 Like