Error in translations manager

Yesterday I was working on an update to a form and found that there is something new and very wrong in our translation manager.

Any suggestions on how to fix this?

Welcome to the community, @tara.russell.jhu! Kindly please be informed that you will have to input all the translation by yourself manually. If you fail to save the changes your should get a blank screen as you are seeing at the moment.

Yes, the translation was entered manually and we have been using the form in three languages for 12 months. The translation just disappeared yesterday when I started to work on an update. Thanks

Would you mind downloading your survey project in an xlsform and see if it’s still present there?

I’m trying that - but I’m getting a 500 server error. I’ll keep trying.

I’m still getting this message when I attempt to download the project as an xlsform.

The table shows the form data with the meaningless labels -

However, when I download the form data, the question labels do display correctly - in all three languages.

What do you suggesti?

Would you mind sharing with us the following through a private message:

  • Username
  • Project name
  • Server

Hi @tara.russell.jhu
Could you start by looking at the previous deployed versions of your form. Try cloning one of them, and then download the XLS form in the cloned project. Do you see your translations in those?


1 Like

The issue is there because you have an undeployed survey form. Try deploying them, and it should solve your issue.

Note: If you have translation issues with this version, i.e., v76 try cloning your v75 and then update the v75 as outlined by @stephanealoo, ensuring the questions and changes that are needed for the project.

Thank you for these suggestions.
I tried cloning the project. However, in the cloned version, I receive the same error when attempting to download the XLS form in the cloned project

I also cannot preview the form in the cloned project

I also cannot deploy the form in the cloned project

Try cloning v74. It should work.

v75 could have issues that are why you are not able to download your xlsform.

Thanks! this is working now. What a relief.

1 Like

Glad to know that it’s finally working for you!