Error: instance xml file does not exist!

Good day!

I am encountering an error when I upload encrypted data. What does “Error: instance xml file does not exist!” mean?

Thanks!

When do you get this error message? Could you kindly please provide us a steps to that we could try it at our end. Would also appreciate if you could provide the server you are using.

My enumerator collected 45 records. 10 records were successfully uploaded, 35 showed the error above. They do not have access to the device, including file explorer as it was configured using knox. We used our own server to host the kobotoolbox.

Thanks!

Would you mind sharing the submission error that you receive. It would be helpful to the community to solve your issue.

This is the sample of the image we’ve encountered. Also, we activated auto-delete and auto-send data.

Is this only an issue for a single device or all of the device that are collecting data for the project?

It was reported that several devices experienced the same error. Is it possible that the device attempted to upload the data then an error occurred during uploading that caused the data to be not uploaded but nonetheless continued with the deleting of data? Hence, the data is deleted after unsuccessful uploading of data.

Thanks

Still not clear.

Is it an issue with only one device or all the device? Could you kindly confirm this.

Several devices. Not all devices but there are devices that have this error.

OK. Seems like it’s something associated with the device or application in it. Could you kindly provide us the following information:

  • Device model
  • Android version
  • Collect android app (version) used for data collection

Maybe these information should help us identify the issue.

Device Model : Galaxy Tab S6 Lite (SM-P615)
Android version : 10
Collect Android app : Kobo Collect v1.27.3

Hello, I would just like to ask. Does Kobo Collect ensures the data is uploaded successfully before it deletes the data?

Thanks

Could you provide me the URL setting (General Settings>Server) for your server through a private message. Let me try getting the blank forms at my end.

Regarding your query:

Yes!

Hi @alexpolo01
Out of curiosity, there are two issues that I would like to get more clarification on:

  1. Is this the first time you are using this particular set up on your own server, and devices that have the Knox security set up?
  2. If not the first time, have you ever experienced this error before?
  3. The only reason is that the error occurs is that the XMLs have been deleted from the device. Could you confirm if your security system also has the potential of deleting the XML files?

As a response, your XML files would not be deleted prior to submission

Stephane

I am sorry sir. As per instruction of my superior, we cannot give out any account outside our organization.

Good day,

  1. Yes and yes
  2. The users cannot access the files from sd card as this feature was configured using knox. The only one capable to delete the xml is the kobo collect app itself using the auto-delete feature.

Thanks

Hi,
Could you please test this system on a device without knox and see if the behaviour will change.

Rationale: I suspect this has more to do with your security settings than the server installation.

Stephane.

1 Like

Hi sir,

Upon checking the database, it turns out the data had been successfully uploaded but the Kobo Collect app did not successfully processed uploaded data and tagged it as “Sending failed” thus the continuous error showing up every time an enumerator uploads data.

Thanks

1 Like