Error: instance XML file does not exist


I am facing an issue with an error message when trying to send forms. I have seen similar posts on the forum but none of them helped me solve the problem we’re facing.

I have 128 forms on the Kobo Collect App on one of the devices (we managed to send the forms from all other devices). When I’m trying to send them, the error message appears which says ‘Error: instance XML file does not exist’. Moreover, when I open the forms, it seems as if there is no data in them, while they do appear as finalised. The device in question is Tablet Galaxy Tab A, SM-T295.

Does anybody know how this issue could be solved?


Welcome back to the community, @mrichter! So you mean you were not able to submit data collected from your android device to the server from one of the devices. Were you able to submit the data collected for the same project from other devices? Could you also share with us a screenshot of the same so that we should be able to understand the issue more pictorially?

Hello Kal_Lam and thank you for your response. Indeed, the issue is on this particular tablet, while we managed to send the data on the other devices.

I am attaching two photos: one of all the survey saved which shows that we failed to send them and the error message which appears when I tried to send one of them again.

Many thanks in advance for your help!


Sharing another picture of the error message as well.

Which version of the Collect android app are you using?

On this device we have Version V1.30.1 installed.

@mrichter, would you mind if something like this has happened with you too?

Hello Kal_Lam! It’s not fully possible to check as the surveys seem empty when we click into them so I cannot confirm if they are already in our database (we have about 2,000 entries). Not sure then if the enumerators filled it in wrong or if there is some sorts of encrypting in place to prevent us from viewing them.

By the way, are you able to edit your submissions that do not get synced with the server?

Hi @mrichter
This behavior mimics a situation where the folders with the instances were deleted. Could you confirm the following checks:

  • Check and see if you are able to open a blank file?
  • Confirm the settings on the application specifically form management and end a screenshot of what you have there. (I hope you re the one who has the device)


1 Like