Error Loading Form - Failed to Fetch


I am trying to preview a form on Kobo and I keep getting the error messaged * Failed to fetach, It only comes up when I try to preview the deployed form but when I preview during editing it loads properly.

Any idea what could be causing this? Grateful for any support!


Welcome @icm_user,

  • Did you check your form with the Online validator?
  • Did you change the form after deployment?
  • Could you clone the form/project and try to preview it?
1 Like
  1. Checked the form with the online validator and these are the errors that come up - any idea how to address these?

[row : 6] Group has no label: {‘name’: ‘g_informed_consent’, ‘type’: ‘begin_group’}

[row : 27] Group has no label: {‘name’: ‘g_planning1’, ‘type’: ‘begin_group’}

[row : 35] Group has no label: {‘name’: ‘g_planning2’, ‘type’: ‘begin_group’}

[row : 51] Group has no label: {‘name’: ‘g_conducting0’, ‘type’: ‘begin_group’}

[row : 60] Group has no label: {‘name’: ‘g_conducting1’, ‘type’: ‘begin_group’}

[row : 67] Group has no label: {‘name’: ‘g_conducting3’, ‘type’: ‘begin_group’}

[row : 76] Group has no label: {‘name’: ‘g_conducting4’, ‘type’: ‘begin_group’}

[row : 82] Group has no label: {‘name’: ‘g_conducting5’, ‘type’: ‘begin_group’}

[row : 89] Group has no label: {‘name’: ‘g_conducting6’, ‘type’: ‘begin_group’}

[row : 103] Group has no label: {‘name’: ‘g_processes1’, ‘type’: ‘begin_group’}

[row : 112] Group has no label: {‘name’: ‘g_processes2’, ‘type’: ‘begin_group’}

The following language declarations do not contain valid machine-readable codes: English, Bangla. Learn more:

  1. The form has not been deployed for actual data collection yet, just in testing mode. And no the form has not been changed.

  2. Tried cloning the project and the error still persists.


Hi @icm_user,

Assuming you are editing this document in xls version, here is how to adress the issues you are facing:

For all of these errors; you need to add labels to your groups in the survey tab.

As seen in the link:

You simply have to name your label::language1 (code) , label::language2 (code) , etc., and your forms will be available in multiple languages.

So for English and Bangla you need to use corresponding codes. Look for the subtag in this document:

If you have further questions don’t hesitate to ask.

1 Like

Hello @icm_user,
these are only warnings, not causing your problem.

Groups without labels are used if you do not want to show the labels, esp. using the grouping for structured coding, like skipping a group of questions by relevant.

1 Like

I’ve tried including the labels and including the language codes but I’m still getting the error failed to fetch - is there anything else I can do? I also tried cloning the project as well.

Also, this error is coming up when I deploy the form and try to preview and when I am creating the draft and I. try to preview. However, when I edit the form and preview it shows up

Hello @icm_user,
could you provide a screenshot of the project/form show all versions page, please.

You may develop a new version, not yet deployed, but having a previous deployed version with data which will be active on edit.
Did you check the NEW version with the Online validator?

1 Like