Error message seen while trying to install KoBoToolbox

Hello dear community I am trying to install kobotoolbox locally on ubuntu OS from with kpi but everytime I am running the server I am receiving this debug error from the django sever “[Errno 2] No such file or directory: '/home/laslie/Documents/kpi-master/node_modules/mocha”. I am stuck here for two days now and don’t know how to debug the error.Any help?

Dear @karlsiaka,

Could you please explain briefly, how did you install the KBT locally on ubuntu? Which Ubuntu OS version do you have? Probably problem is occurring due to incompatibility at the installation phase.

1 Like

Ok so I downloaded the Kpi repository on my ubuntu

,because I would like to download the kobotoolbox without docker so since the project is running on Django framework,my purpose was to install all the different dependencies on the virtual environment.So when I run python migrate I had this message errors that appear “ValueError: Cannot quote parameter value [] of type <type ‘list’>” and when I run the server I see this on the debug window of python " [Errno 2] No such file or directory: '/home/laslie/Documents/kpi-master/node_modules/mocha"
ps:I am using ubuntu 19.10

The error message on the debug window

Based on what I can see here, installation lines are seamlessly correct. Are you sure that you have all dependencies at the same directory?

Also did you try to installing it before on Django? If you did not remove the old installation files it may cause No such file or directory error. Make sure that you clean everything and try again.

In your case, I would remove everything from the virtual environment and try installing it from scratch.

Hello mcaglidil I keep having the same issue as I previously mentioned. If you look well on the first screenshot, you will notice that there are app dependencies that cant migrate, and this is a serious problem also.I feel there are some dependencies which are deprecated and cause this.Can you try to install it on your machine so we can see if you encounter the same issue?-