Error message: 'Software caused connection abort'


I’m using Kobocollect to collect data - photographs, videos, audio recordings, and GPS location.

Over the last three weeks we have suddenly been receiving the following two errors intermittently across the team:

  1. “Software caused connection abort”; and
  2. 'Unable to resolve host “”: No address associated with hostname".

We tried reinstalling Kobocollect (and in some instances factory-resetting the phones as well). This solution worked for a while, but we are still getting this error on the same phones (participant) intermittently - i.e., some submissions from the same phone come through, while others do not. In all cases, when data is not submitted, it is the videos and voice recordings that do not get uploaded, but all photographs are uploaded.

Has anyone else faced this and if so, how did you resolve this?

Thank you,
Kimberly Noronha

@knoronha, could you also share a screenshot with the community? Could you also let the community know the total size of the videos and recordings you are trying to submit via the app? If the file size is large you could face submission issues.

1 Like

My apologies for the delayed response. Here are the screenshots as requested.

Regarding the video sizes, I don’t think that’s a problem because per your earlier suggestion, we have enabled large video/audio file uploads in the app. Since then, we have successfully received videos of up to 35 MB. Additionally, we receive recordings of up to 3 MB as well.

@knoronha, are you still stuck with this issue? Apologies for the delayed response.