Error message: Unable to deploy (even with no errors in the online validator)

I know many others have posted about this problem but I’m desperate to find a solution for my form. I deploy the exact same code everyday and for some reason today I get the following error in the legacy interface:

500 Error
If this is a significant error that needs to be fixed, please send a support request to support@kobotoolbox.org with information about what triggered this error.

On the other hand, if I try to deploy my project on the new interfase, I get the following error message:

unable to deploy
no puede implementarse su formulario porque contiene errores:
Expecting value: line 2 column 1 (char 1)

I’ve already ran it through the online validator suggested by Kal_Lam in other posts and I’ve corrected the errors suggested by the tool to the point of getting no errors back. Still, KoboToolbox won’t allow me to deploy.

Any ideas about how to get around this problem? Thanks a lot in advance for your help! My xls form can be downloaded from the following link:

Hi Kal_Lam. I’m having the same problem with this exact error but the exact same code works just fine in the legacy interfase. Is it possible that some sintax errors go unnoticed in the legacy interfase while preventing the project to be deployed in the new interfase?. I would very much appreciate if you could help me find the errors in my code since time is of the essence for me in my project. Thanks!

Hi @basualdo

FYI, our developers are having a closer look at this case! Thank you for you kind patience!

Hi @basualdo
I would like to confirm that the issue has since been resolved and you should be able to deploy your form as long as it does not have any form design issues. Kindly check and confirm if you are still experiencing the problem. We apologize for any inconvenience caused.

Stephane

1 Like