"Error occurred during the loading of this form" related to pulldata csv file, I think

Hello! I am trying to use pulldata from a .csv form but I get an "“Error occurred during the loading of this form” message when I try to preview the form.

This is my calculation: pulldata(‘adm2data’,‘Priority’, ‘admin2Name’, ‘District’)

I am a new user to this community and I cannot upload my form.

Can anybody see what I am doing wrong?

Welcome to the community, @hayttom_ocha! Have you validated your xlsform through this online validator? It should help you identify the syntax errors that are present within your xlsform.

Hi Kal_Lam,

I had not tried that but I have just done so and it does not show any errors.

When I preview the form everything looks good and it says my form is valid. But I get an error message when I try to open it.


Would you mind sharing with us your xlsform as well as your csv file so that we could have a closer look at it? If you feel it should be treated confidentially, you could share the same through a private message.

Hi Kal_Lam,

I can’t - it says new users cannot upload.

Meanwhile I have got pulldata to work properly on a completely fresh form and now I am trying to add my original questions, so it might mean that everything is OK. I’ll come back here tomorrow if it isn’t.

1 Like

Glad to know that it finally worked for you. Feel free to reach us back if you have any issues. BTW, please be informed that you should now be able to upload your xlsform to the community.