Error trying to parse XML record. Different root nodes when trying to edit a submission

I am experiencing the following problem.
Please suggest the way out. This project was started in 2020 but paused until today. I resumed the work today but could not edit the form.
It is a little time sensitive.


Could you also check the form with the Online Validator, please: ODK - XLSForm Online v2.x ?

1 Like

You might try to find the previous version (see History view), clone it, download and upload and deploy it to the original project. Maybe you need to remove the version row/column in the survey and settings sheet.

After this, you should upload the newest version and re-deploy it again without changes, to avoid confusion with the older temporary version.

With the search function of the forum, other examples causing the same error, can be found: Search results for 'error trying to parse XML record. Different root nodes' - KoboToolbox Community Forum

1 Like

@sanchaya, do you get this error message when trying to edit a submission from the server or when trying to fill up a new form? Did you also try to validate your XLSForm as advised by @wroos?


I validated the XLSForm as advised and it worked!

Thank you so much for all the help.

1 Like

Hi, I’m having the same error. I’ve checked the forums and it appears as though this might need to be fixed on the kobo end. I emailed kobo support and @Kal_Lam recommended that I post here.

The form was deployed in 2018 and I have not made any changes since. I frequently edit submissions, as recently as a few weeks ago it was working fine. Please let me know if you have any suggestions.

Thanks in advance for your assistance


@sanchaya, could you also explain all the details you underwent so that it would help @livingcollections troubleshoot the same?

Sincere apologies for not being able to get back on this earlier.

I just validated the form as suggested above and removed the fields which were no longer supported.

I hope this helps.

Could you add the details, please, which fields you had to remove and maybe other changes?