Error trying to parse XML record. Different root nodes

I there, i cannot edit a submission report, it gives me the follwing error:

Can anyone help?

Same problem, mine eventually fixed itself after closing and opening the browser multiple times/leaving it alone and looking at it later.


I’m having problems to edit a form, the error message its this one:

It only happends in this project: ROTURA_BEIRAS (roturas_registo_2)

My username is: xxxxxxx

I really need to edit those forms to properly donwlad it.


@aalcada, @mkmortera would you mind validating your XLSForm through this online validator to see if there are any syntax issues?

1 Like

Hi there,

His giving me this output:

It only started to do this yesterday, i edit without problems in friday. This only happend with this project, the others work fine.

Im going to add the xls file
amnQ4QGtNMReABp2QCax4u.xlsx (6.6 KB)

Hello @aalcada,
Validation seems ok. These are only warnings (might be related to a new Enketo/ODK feature to limit image size).

Hello @wroos,

I dont understand either, this only started to happend yesterday and only with this form. They are comming without problems with Kobocolect, the problem is when i try to edit the submissions in enketo.

Hello @mkmortera,

Mine is still doing the same, i already erase cookies, and is giving me the same error.

@aalcada, as a quick check would you mind upload this as a new dummy project and see if it behaves in the same way? Kindly please let us know on what happens.

Sorry, but where is the file?

@Kal_Lam i just made a test, that was creating an Enketo, and the i tryed to edit, and it worked!
I think its only, the forms that come from kobocollect.

Hi @aalcada
Could you please explain what you meant by this?

Hi @stephanealoo,

So what happend its that i redeployed the project again in the Enketo (web app), and the users didn’t update in the android app that same project. So what’s happening now, its that i canno’t edit the form that its arriving from that users, because it’s not updated in their end. I hope you understand what im saying, English its not my native language. Thank you all for the comments, but its solved. Best regards.

1 Like

@aalcada, :clap: :heart:

Hi there,

It’s happening again, and this time i had not make any changes in the project. I canno’t edit any form it gives me the exact same error. Did you update the app in android, or something like that?

Best regards.

Welcome back to the community, @aalcada! Could you share with the community a screenshot of the issue? This should help us better understand the issue.

Hi @aalcada, can you please send me the following details in a private message so that I can investigate:

  • username
  • server (humanitarian/non-humanitarian)
  • project
  • _ids for some affected submissions (unless it’s all the submissions)
1 Like

The erro is the same, when i try to edit or view it gives me this error in the image

1 Like

Hi there,

It is giving me the same error "Error trying to parse XML recor. Different root nodes.

Can someone help me? I try to talk with Josh, but with no sucess.