Error Trying to Share Forms via URL

Hi all, I have an issue with sharing a form via URL. I am testing this myself and have shared a form to my personal email and used a separate Kobo login to access the file from the URL generated from the Settings page of the project.

I can see the project page and using the preview button I can see the current version of the form.

However, when I tap ‘Open’ to start a data collection session I get an error message which reads -

Loading Error This form does not exist or you no longer have access to it. Please check the URL for any missing characters. If the form existed previously, it may have been archived, disabled or deleted. If this is unexpected, please contact the person who asked you to fill the form.

This message comes up regardless of what type of data collection session I select. I’ve also noticed that this is happening with other forms too, I haven’t been able to successfully share one yet. I am testing this on iOS and have tried the Safari and Chrome browsers with the same result.

Finding this very odd as the form can be accessed as a preview but not for data submission! Anything I should be looking at? Thanks!

Did you deploy the form (version)?

1 Like

Yes, this is happening with deployed forms.

Did you go through the Help Center article, please, Sharing Your Project and Managing Permissions — KoboToolbox documentation and make sure you set the relevant permissions?

1 Like

Yes have been trying to solve this myself by reading these articles but not getting any answers.

As far as I was aware the point of setting the project to be publicly shared with anyone was so that anyone can collect and submit data on a web form without needing to set any permissions. The form should just be accessible by all?

I have checked the box to allow anyone to access the form. Is this not the correct way to allow anyone to collect data with the form via the web?

@peat, could you kindly share a screenshot of your issue with the community? Please also let us know the server you are using. These details should also help us troubleshoot your issue.

Thanks, @Kal_Lam.

I have the project shared in my Settings like this -


When I access it on a device not associated with this Kobo account via the URL provided I can see the form page like this.

When I tap on Open to begin data collection I get this error.

If I also select ‘Anyone can view submissions made to this form’ I can see the Data tab as well as the Form tab, but still can’t collect any data.

I have semi-solved this myself, unchecking ‘Require authentication to see forms and submit data’ has allowed me to see the form, but only when logged in with a Kobo account. If I am not logged in I cannot see any data submission options. The web version of the form also isn’t displaying images.

Is the sharing of the URL not meant to allow anyone to access the form?