Error unknown error node ofr itemset doens't exist

Continuing the discussion from Select One or Many From External File Question Type issue:

The form works fine when I preview the form or open it via:


However, when I try to open it in ODK Collect or KoBOCollect, then I receive the following error:


Could you kindly help me to fix this problem?

Thanks in advance!

@Webex, I assume there should still be some issues with the CSV file. Would you mind having a closer look at it to see if you are able to identify any within the CSV file?

I have two CSV files:

I took into account if the names are unique by assigning a number to the name. The list_names within the CSV’s are the same.

In the community I found a lot of information about an error in select_one_from_file, might that be the problem?

@Webex, I observed that you are using a wrong CSV format for BarCodeSpecial file:

Image 1

You will need to restructure your CSV file with the following structure:

Image 2

Doing this should solve your issue.

If I download, than, excel doens’t show what you observe with the " ; " in the table, but it is already restructured as you show it now. Can there something going wrong with uploading my files that it becomes structered with " ; " in it?

After uploading “BarCodeSpecial” restructured (as in your picture) to the server, the survey works with enkato. However when using kobo collect, the pull data does not work. When I adapt the the CSV file with concat in excel to one column and upload the file to the server, the pull data works in kobo collect.

Hello everyone :slight_smile:
How are you?
I am having i think a similar issue, but i didn’t get if you found a solution. Did you?
It does work on-line in enkento, but not in KoboCollect app… am i doing something wrong?
Thank you very much!

Hey Hey i found the solution, so i share it:

In enketo it works when saving the CSV as CSV UTF-8 (delimited by coma) (*.csv), but with this format it doesn’t work in Kobo Collect app

However, saving it as CSV (delimited by coma) (*.csv) it works in both!

So for my side it has worked when NOT using the UTF-8

1 Like

Dear Quentin,

Thanks for the feedback!

1 Like

@Quentin, :clap: :heart: :partying_face:

Hey Hey, pleasure to be back over here Kal_Lam, i did 2 years in another position and now back into Kobo work :wink:

1 Like

The community should benefit from your presence and knowledge @Quentin! :books: :open_book:

As i benefit a lot from its existence :wink:

1 Like

I have the same problem, I have made the CSV the right format as delimited by comma *.csv , I checked the structure against the examples, and I still get the same mistake as below

This is what the CSV looks like
kobo issue district csv shot

Can someone help? @Kal_Lam

@andre_ch, we would appreciate it if you could avoid making multiple posts for the same issue. Doing this should scatter the issue. Let’s continue your discussion here: