Error when trying to add rating questions to a form from a library block


I tried to create a question block of six questions - one rating scale (with two options per row - yes/no) with five rows, and five number questions afterward. (This was to replace a matrix question that wouldn’t have worked in the Android app.) When I tried to add the group from my library, I got this error message.

Steps to Reproduce

  1. Create a new question in the library that is the ‘rating’ format.
  2. Drag it from the library pane to the form you want to use it in.
  3. Get this error message:

Expected behavior

I expected it to add the rating question!

Actual behavior

It gave me error messages and only added the five number questions in the block.

Additional details

I’m guessing this is an issue in the library of recognizing and replicating rating questions, but to be honest I’m not a coder outside of SPSS so it’s only my best guess! I used this as a workaround because there was no option to add a ranking question directly to my library from a form, so I should probably have expected this!

Edit: Kept using ‘ranking’ when I meant ‘rating’. Apologies!


Hi @lbrander,

Welcome to the community! Thank you for bringing this to our attention. Kindly please be informed that I have created a GitHut issue for the same here:

Have a great day!

1 Like

Oh that’s great! Thank you!