External instance is empty


I have kobo installed on my local machine (MacOS). I have been trying to use the pull data functionality for one of my form and it keeps saying that the external instance is empty although I have uploaded the CSV file from which I need to pull data.

Can someone help? Thanks!
Screen Shot 2021-07-16 at 2.48.02 PM

@saumyaupadhyay, would you mind sharing the section of the xlsform that holds the pulldata function and the CSV file? Maybe the community should be able to help you out.

Hi @Kal_Lam - I have sent you the CSV and xls forms in a private message. Please take a look and let me know! Thanks!

Hi @Kal_Lam - Did you get a chance to review the documents I shared with you over message? Please let me know! Thanks!

@saumyaupadhyay, when looking at your xslform and your csv file I could see the following:

Your xlsform:

Your CSV file:

Image 2

Issue number 1:

If you look at your xlsform (where I have marked 1 of key, they do not match the header name you have specified with your csv file which has Key. So, here you will have to make them either key, Key or provide a different name in both the places.

Issue number 2:

Line 6 of your xlsform has a select_multiple question type. You have tried to use a pulldata function for the same which is not supported. If you wish to use a select_multiple from a csv file you will need to use other approaches such as select_multiple_from_file as outlined in this support article Select One or Many From External File Question Type.

To learn more on pulldata, feel free to go through our support article Pull Data Functionality in KoBoToolbox.

Hi @Kal_Lam - Thank you for your response! I have tried the solution you provided and following are the changes I made:

  1. Removed pull data functionality for the select_multiple type question
  2. Updated key to Key in the xlsx form

After making these changes, when I preview the form, I get the following error:

Also, when I open the form link, I get a different error:
Screen Shot 2021-07-26 at 11.19.35 AM

Here are the xls form and csv files:
aT6UmEkGxAaakhVykH5q3m.xlsx (10.4 KB)
employee_pull_data.csv (114 Bytes)

Please let me know what these errors mean and where I’m going wrong! Thank you!

Hi @Kal_Lam - Let me know if you were able to reproduce the issue/error on your end. Thanks!

Hi @saumyaupadhyay
There seems to be an issue with a CSV referenced in one of your pull data functionalities. The CSV is labeled 43.csv. Can you test this form within our server instances and see if you have the same problem.


1 Like

Hi @stephanealoo - Thanks for your response! I checked on the Kobo server instance and the forms worked there! Does this mean there is an issue with my installation? FYI - I have installed Kobo on a Mac using kobo-install. Also, I tried to install a fresh version of Kobo but that didn’t solve my problem either. Can you help, please? Thanks!

Hi @stephanealoo - Any inputs here? Thanks!

Hi @saumyaupadhyay, I have just moved this thread to the “KoBo On Your Own Server” topic. Can you please let us know what version of Kobo you are running locally?

1 Like