Failed to load data from csv file in enketo


I am having problem loading my form in enketo. This error pops out while loading.

The problem just appeared in enketo. The form loaded well in KoBo Apps.

@saadiah_ghazali, have you redeployed your survey project after uploading your CSV file? That should solve the issue.

Hi Kal, yes I redeployed every time I uploaded a csv file. The KoBo Collect Apps works fine. Problem just through Enketo

If this is the case maybe it’s an issue with the structure of your CSV file. This post discussed previously should help you understand on what I am trying to refer:

Hi Kal,

None of the issues are the same as the ones I have. Attaching here is the csv file from which I want the data to be pulled. Cresp.csv (849 Bytes)

Here is the screenshot of my xls form.

@saadiah_ghazali, could you share your CSV file in this format:

Hi Kal,

Here it the file in UTF-8 format Cresp.csv (849 Bytes)

Did it still not work?

Hi Kal, yes still didn’t work. Today the error change to this


@saadiah_ghazali, could you also validate your xlsform through this online validator to ensure that other syntax used in the xlsform are OK?

@Kal_Lam, the only errors that appeared are these:

  • [row : 6] simserial is no longer supported on most devices. Only old versions of Collect on Android versions older than 11 still support it.

  • The following language declarations do not contain valid machine-readable codes: Telugu, English. Learn more:

@saadiah_ghazali, maybe you will now need to share your xlsform and the CSV file with the entire community. The community should be able to help you out.

@Kal_Lam , I can’t share the complete xlsform but I can share it personally to you if that helps.

Please feel free to share it.

Hi @saadiah_ghazali, can you please specify which server you are using (HHI/OCHA) and if you were facing this issue before 29 September 2021 or only after.

1 Like

Hi @Josh . I’m using the researcher account by kobotoolbox and I faced this problem only after 29th September.

@saadiah_ghazali, when reviewing your xlsform, I observed some form design errors:

  • Use of - in the variable name under the survey sheet.
    Image 1
    You could replace the same with b05_b14, d02_d05 and so on.

  • Use of spaces in the variable name under the choices sheet.

    Remove the space and use the _ instead of the spaces. So you could maybe rename the variable as Metric_tons, Maund_40_kg, and so on.

  • Use of - in the variable name under the choices sheet.
    Image 3
    You could replace the same with ISEGERO_MAILO instead.

Fix those issues, and you should be able to deploy your survey project without any error.

1 Like

Hi @Kal_Lam . Thanks for the suggestion. I will update the form and redeploy.

1 Like

Hi @saadiah_ghazali, were you able to resolve your issue?

Hi @Josh. Updated the form based on suggestions by Kal. However, still fail to load the form in enketo. For kobo apps, its working well.