Failed to update permissions

Welcome to the community, @comcat! Could you also let us know the total number of users you have applied permissions to?

Hello , am also having the same problem…I can’t update permissions of one of the users that I added to the project. It always brings the message failed to update permissions. It’s on 1 user only as for the others I can update. Please help

57 people. 55 can add submission but around 4 can’t add submission and some of them are not being able to access the form. @Kal_Lam

@bridgethac, @comcat, could you remove all the sharing permissions again and then reassign? Maybe sometimes dosing the said should help you assign smoothly. Please let the community know what happens.

I removed each user from the sharing and then reassingned, but still… It keeps leaving 2 people with out submission permition. And when I try to give them this permission the message appears “Falied to update permissions”

@comcat, so what is the total number of users to whom you have assigned permissions successfully?

We had the same issue with new users added and impossible to update their permissions. We have about 11 - 12 users in total. Also one user that previously had permission to submit data was affected.
As it turned out, all usernames that were affected from “failed to update permissions” error started with “a”. Once we changed usernames to start with “b” we were able to set or update their permissions.
Hope this helps @comcat and @bridgethac.

1 Like

Welcome to the community, @msECO! Thank you for sharing the solution with the entire community! :clap: :heart: :partying_face:

seria interesante conocer porque se da este problema @Kal_Lam , ya que ahorita me esta pasando lo mismo, con un usuario cuyo nombre inicia con “a” pero no habiamos tenido problemas anteriormente. Ahora no lo deja enviar información y tampoco permite cambiar permisos.

Gracias por la información.

@raquelchaicoj, could you let us know the total number of users you wish to manage permissions to? This information should help us troubleshoot your issue.

hola @Kal_Lam es solamente un usuario, cuyo nombre de usuario es xxxxxxx
Este usuario estaba funcionando bien, pero de un momento a otro ya no pudo abrir el proyecto, ni enviar información. Intente actualizar los permisos per salia error:
Así mismo, el error que le aparecia a él era el siguiente:

En el proyecto participan 26 usuarios, pero solamente uno esta dando problemas.


@raquelchaicoj, could you also let us know the server you are using? I could have a closer look at your case then.

Good Morning.

I have the same issue with a user. They have permissions to edit and add submissions in other forms, but for some reason, I cannot change their permissions in 1 project. I have tried deleting them from the project and re-adding them, but it still fails. I’m on the Research server. Any ideas? Thanks.

hola es el humanitarian (

es posible modificar el nombre de usuario sin tener que crear un nuevo usuario?

Hola @raquelchaicoj,

¿Puedes probar esto?

  • Eliminar el acceso público
  • Cambiar permisos
  • Volver a poner el acceso público

Hay una problema con los permisos ahora. Vamos a implementar une solución pronto.

1 Like


Can you validate if your form has “Public access” enable? (look at the bottom of the sharing permission modal). Deactivating it temporarily while modifying the permissions can help.

We’ve identified an issue that should be fixed and released soon.


Thanks, that worked great!

Also want to give a huge thank you to the entire KoboToolBox team. The great code and service you provide makes a huge difference to so many caring efforts.

Best Regards,


hi @comcat, were you able to fix this one? I hope you can share what worked for you. we are currently experiencing the same issue (failed to update permission for certain users, but have successfully added other users). we have tried all the suggestions that are currently available here but did not work

hi @Kal_Lam. total number of users that were successfully assigned with permission is currently at 38. we are using the non-hum server

@hm11, FYR: