Form can't be deployed "No Json object could be decoded"

Hello! I’ve been having this problem since friday. I added a field where I get a note depending on the location the person introduces and I have one problem and one thing I need my form to do.

  1. I deployed a form that pops up a note when someone introduces a rural location and another note when its urban, and that worked fine… When I introduced two other notes for indidigenous territory and border community (there are some places that are both categories + rural or urban) So… When I deployed the form it gives me this error…


I found someone that used a tool to find out what this means and it gives me this error


So, right now I don’t know what to do…

  1. The next thing is… I want the file that I download with the data to show me which entry popped up which note… Is that posible?

This is my xlsform, I’ll be very happy if you could help me!

Cápsula Informativa.xlsx (76.7 KB)

Thank you in advance

Hi @analucia_espinoza,

Observed that the syntax you provided in the relevant column had issues. I removed them and the form you shared could be deployed successfully without flagging any error message.

Reference xlsform:
Cápsula Informativa.xlsx (74.5 KB)


1 Like

Hello, thanks for your answer, but you didn’t understan what I wanted to do… I clasiffied every “parroquia” or location to know when it’s rural, urban and when its indigenous or a border region, that’s why I had the the selected () in the relevant column, so when I picked a location the form would tell me if it’s rural or urban, and if it’s indigenous and if it’s a border location… So… Some of them are rural and indigenous and border, others are rural and indigenous , other… rural and border, other., just rural… and the list goes on…
The form you shared tells me all of the categories, all the time, without picking a location and without classifing them (which is exactly the opposite from what I want)

The thing is… the classification with selected() worked fine for rural and urban categories… the problem started when I added indigenous and border, I don’t know why is that, and that’s what I want to solve

Hi @analucia_espinoza,

Just wanted to flag you out that the error message you had been seeing was due to the syntax error within your survey form. My recommendation would be “Try making your syntax short and precise”.