Form content not visible in Enketo while collecting data

We have tested this draft form with our country staff and a couple of them see no content on the form. As you can see on the screen shot below, no questions, hints, or options are displayed, and the issue is the same throughout the form. Since most people have had no such issues, I am not sure if the issue is with the form itself or somewhere else? These issues have been reported from Ethiopia and Myanmar.

I tried to upload the xls form here as well but apparently I am not allowed to do so as a new user.

Hi @Suvi,

You should now be able to share the xlsform. Would you mind trying it again.

Have a great day!

do you use different languages?
Did you define question and choice labels, hints, guidance hints for each of the languages?.

1 Like

Hi @Suvi,

Would you mind checking out your survey form as indicated by @wroos to see whether the questions and choices for certain variables have been completely translated. Sometimes you happen to see this issue when the translations are incomplete. As a workaround please have a look at a simple example shared below. It is similar to what you have shared in the screenshot:

Checking incomplete translation through KoBoToolbox Form builder UI:

  • Check out the following (marked as 1 in the image below). There should be at least 2 languages in your survey project. Then press the globe like icon (Manage Translations) (marked as 2 in the image below).

  • Press the earth like icon (Update Translations) as shown in the image below:

  • You should then see an incomplete translation as shown in the image below:

  • Complete the translation and press SAVE CHANGES. The issue should be solved.

Checking incomplete translation through xlsform:

  • Download your xlsform and check out the survey tab of your xlsform. It should be something as shown in the image below:
    Image 1

  • Also check the choices tab of your xlsform. It should be something as shown in the image below:
    Image 2

  • Also check the settings tab of your xlsform. It should be something as shown in the image below:
    Image 3

  • Complete the translation. Save them and replace them. Finally redeploy them. The issue should be solved.

Reference xlsform:

Incomplete Language Translation.xlsx (12.4 KB)

Have a great day!

Hi @wroos and @Kal_Lam,

We use English only (at least for now). However, I noticed that we have 2 different English versions. Could this be the reason?

Here’s the xls form
axfSAKQRjAazK86wodLTnV.xlsx (8.9 KB)

So if I just remove English (en) and keep the default language as it is, the problem should be fixed?

1 Like

Hi @Suvi,

Caught that correct. I could also see the issue in your xlsform:

Use only one label::English (en) or if you have only one language you need not even specify them. You could simply keep them as label.

Have a great day!

Thanks! The country staff tested it again and now it’s working fine.
Also good to learn how the translation feature works, we will probably use it in the future.
Have a great week!

1 Like