Form Encryption Issues

Hello everyone,

I’m currently trying to encrypt a form. I followed all the steps from this article on Encrypting Forms and the encryption part seems to work as I can’t see the data (other than metadata) even though it shows nowhere on the UI that my form is “encrypted”.
But when I tried to decrypt it using a openSSL-64 generated key with ODK briefcase it doesn’t work. With the latest ODK Briefcase version the export is going forever without anything happening and with previous versions (1.16.x) it either says “Export has started” then nothing or “Export 0 of X submissions completed”.

It is also important to note that depending on the version of ODK briefcase the pulling part shows either “Success with errors” (1.17.x) or “Success” (1.16.x).

I looked everywhere for answer but can’t find the cause of my issue and I would be extremely grateful if someone could help me out on figuring this.


Hi @ybourgeois,

Welcome to the community! Have you tried decrypting your data with ODK Briefcase v1.15 . It should solve your issue.

Have a great day!

1 Like

Hi @Kal_Lam,

Many thanks for your reply. It solved the issue.

I can only praise the effectiveness and reactivity of this community support.

Warm regards,