Form submission failed: this record ID already exists, please change it


Unable to submit data collection form created / validated / test form submitted in the United States when collaborators in Cote d’Ivoire click the link and submit the form.

Description of the :bug: bug or a :rocket: feature; you can also add one of the labels: bug, enhancement, ideas or question

Steps to Reproduce

  1. Enketo Express for KoboToolbox
  2. Fill out the form in Cote d’Ivoire (works without issues in the United States)
  3. Click submit

Expected behavior

What you expected to happen

Form Submission

Actual behavior

What actually happened, you can add screenshots if applicable

Pop-up Form States "Submission Failed: the record name or ID already exists, Please change it. Record Name: ____; "

Even when record name is changed, same issue persists

No pop-up or similar issue when form is submitted and filled out in the United States

Additional details

Your environment, why you think this might be happening, or stuff you tried that didn’t work

Re-Deployed form
Refilled and submitted a test form in the United States w/o issues
Asked collaborator in Cote d’Ivoire to try form resubmission with same result

  • What should topics in this category generally contain?

Data collection

  • Do we need this category? Can we merge with another category, or subcategory?

Welcome to the community, @daryakizub! Could you also add a screenshot of the error message you have been seeing? The screenshot would also be a pictorial representation of your issue that would be easy for our community to understand.

BTW, could I also test your URL by sending a dummy submission to see how it behaves from my end?


Thank you for your reply. You are welcome to do a dummy submission since we have not started to collect data. Please see screenshots below. Thanks!


Hello, I am just following up. I appreciate your help!

@daryakizub, I could submit a dummy submission without any issues. FYR:

I did this through Chrome. Maybe you will also need to try other modern browsers like Chrome, Firefox, Edge, etc.

@daryakizub clearing the browsers cache solves this issue most of the time.


Thanks! Now it is working.

1 Like

@daryakizub, @hakan_cetinkaya :clap: :heart: :partying_face:


See that this issue was reported as a bug a month ago. Thanks for that @daryakizub.

We have been encountering this problem for a while now, particularly on two forms. We use the Chrome browser. Clearing the cache resolves the issue. However, the form entry has to be done all over again. They are very large form entries, that can take anywhere from 15 to 45 minutes! There is quite a bit of frustration among users as you can imagine

Would really help to know what is the root cause of this problem at the least, if it can be fixed soon, or if there is a fix currently which does not require clearing the browser cache, i.e. losing the current form data entry

There is no way (for me at least) to create a test form to consistently reproduce this issue. Its occurs unpredictably

thank you all for your help

kobotoolbox issue - record name or ID already exists - error log.csv (4.1 KB)

Sharing two files regarding this issue:

  1. a screenshot jpeg of the error message, with Chrome developer tools console open on the side
  2. A .csv file containing the error log dump from Chrome developer tools console (.csv is the only ‘text’ file format that I could upload this information in)

Another user in our team just got this error on clicking the Submit button of a form

Hope this information helps in troubleshooting this issue and fixing it

Will be happy to help in any way I can to fix this issue. Its becoming a serious problem. Please help


I am having the same issue.

I have a feeling it is related to different deplaoyment (versions) of the form.
When I start a new form it works.
When I use a “save as draft” I get the error as mentioned above.

As a solution I have asked the data collector to “export” the draft version. Then I have made a bulk upload and editied the form in Kobotoolbox.

I would be careful not clearing the browser cache and cookis, as this will delete the saved entries!

Any suggestion to solve this without exporting and sending manually?


We do not use the ‘save as draft’ option for other reasons. Our forms are, for the most part, being used in online mode. Clearing browser cache is the only practical way to deal with this problem for us.

Our users are doing the ‘clear cache’…for now. However, the forms are long and it is a lot to ask to fill and submit the same entry all over again

I was able to resolve this issue after the data coordinator for our project updated her version of the web browser she was using. In our case, it was a web browser issue. However, if you are sending a survey out to multiple participants to fill out, especially outside of the United States, they may also have issues submitting if their browsers are not up-to-date. For this reason, our group switched to using SurveyMonkey for surveys where we need hundreds of individual responses from participants who fill out the survey electronically. We are still using KoboToolbox for our other project where only the study coordinator enters data from paper surveys. I hope the issue of browser compatibility can be addressed by the KoboToolbox team so that we can use this tool in the future.


Is there any new suggestions for this issue.
We have two inspectors who get this error. All other (40) can submit.
One of these inspectors have first used his mobile (android) and then reentered the survey on his laptop and get the same error!

I noticed that someone above mentioned a problem outside USA - but we are all working in Nepal and have no issues except the two inspectors.

We need some advice how to proceed!


Just to report we are having the same issue. We are working across 9 countries, including US. This happened to someone in the US, even if she was able to save and submit forms from the same computer and browser before. We haven’t made any changes to the form, so that is not causing it.

This is is leading to some important frustration, so we would appreciate your help.

1 Like

I have same issues, we are using phone and Kobocollector, how we can in phone clean cash and will it help?
We need some advice how to proceed!


Dear Kai Lam

It seems more users are experiencing these issues without any solution from KoboToolbox.

The solution suggest in post 6 is not a good sulution. When you clear the cache of the browser, you delete the draft surveys and the survey currently in the browser!

You help will be much appreciated.