Gateway timeout when importing XLS on Kobo Docker installation

Hi all,

I am new to the forum and hope that somebody could help me out with my installation. I have installed Kobo Toolbox running on Docker using the installer script. After a couple of small issues I have it up and running. My wife is currently creating all the forms for a survey.

She asked me to help her out with adding media files, at this moment I followed another tutorial and I tried to import an XLS. Here I noticed I was unable to import any XLS in our setup. Importing the XLS in another Kobo online does work, so it is really the import function on our own local docker environment.

I tried different browsers and noticed the folowing error in de debugging window.

Failed to create import:


​responseText: “\r\n504 Gateway Time-out\r\n\r\n

504 Gateway Time-out


status: 504

​statusCode: function statusCode(e)

​statusText: “Gateway Time-out”

I have no idea what caused this gateway timeout. The template XLS is not particulary large. Is there anyone that can point me in the right direction to fix this problem? Thanks so much.

Best regards