Generic 500 error in Sending the collected to the Kobocollect app

I need help with a project I am currently working on. Some of the data collectors are unable to send the finalized forms to my server indicating a Generic 500 error message. Please help me

This is a screenshot of the error message

Please help me out here sir. My enumerators are already in their different regions collecting data. In the beginning around Feb. 8 the submissions were fine but recently all the forms they are trying to send does not work and it shows an error message. Kindly help me out please. Thanks

Hello Kal,
I would really appreciate your assistance in a similar error I am receiving from my data collectors please. And the issue is they cannot delete those forms since there is data in it from different schools and regions.

Welcome to the community, @Mariatou! Have a couple of questions that should be helpful for the community to troubleshoot your issue:

  • Is your server URL configuration set correctly? Could you also share with us a screenshot of the same?
  • How did you get the blank forms to the device? Did you get them by pressing the Get Blank Form?
  • Lastly, would you mind checking the date and time of your device to see if they are all correct?

I used the kf server and I believe it was set correctly I’ll send you the screenshots. I got the blank form after setting up the server. The phone’s are upto date.

This is a screenshot of one of the devices. There are four more devices connected.

Greetings Kal,
Yes the five devices doing the collections are upto date and in the beginning the forms were submitting and stopped sending on 10th february.
Before getting the blank form, I first entered my server details and got the form. I would really appreciate your help on this please. The survey is almost complete now and I have asked the enumerators to stop sending the saved forms now.

OK, I see that the form you are trying to fill up is a shared project. Could you request the admin to remove the sharing permission and assign it again? Kindly please let me know what happens when you do this.

Okay I will do that

1 Like

I have done that and it’s still not working and impossible to send the forms to the server. The same error message pops up .
I have even tried to click on get blank form to see what will happen but this message pops up.

OK so you are also not able to get the blank form to your app?

OK, maybe configure the app with the admin credentials to see if you are able to submit the submissions to the server?

If I change the server settings to the admin. Will they be able to send those completed forms to a different admin?

Greetings Kal,
I have changed the server settings to the Amin’s and the forms have been successfully sent. Thanks a lot for the help. Appreciate it
Kind regards

1 Like

Thank you for confirming @Mariatou!