Group missing while filling a form

While using Kobo collect, a group is missing from the given format. A part of the data( group) is always missing. I have tried with different devices and the problem remains.

Steps taken: Get blank format> get selected > fill blank format. Then after selecting the file, there should have been questions in 3 groups. I find group 3 after group 1. Group 2 is somehow invisible.

*Is it a bug or something else. I am not sure.

My colleagues are using the same format, url, username and they have no problem. They are seeing the full format ( group 1,2 & 3) while I can’t see the full.

I tried uninstalling the app & reinstalling again. I tried using other devices. I also tried resetting the app, deleting blank forms & downloading them again. The problem doesn’t go away.

  • Is it data loss? Or data is skipped somehow?

  • I have searched for this problems. Couldn’t find any. I hope your helpful reply can assist others too.

*This is a form from

Hi @Nina,

Welcome to the community! Have you tried this with Enketo aka web-form? Do you see the same issue there? My hunch is that it should be a form design issue.

If you see the same in Enketo too please try sharing your xlsform with us so that we could have a look at our end.

Have a great day!

Thanks Kal! The problem dissolves using enketo. Could you tell a little bit more why is this happening?
Do I always have to use enketo instead of Kobo collect?
##More importantly, you said it may be the design issue. But where the design issue is coming from? Is it when the questioner is making the question format? Or, is it sort of bug from the app itself? Or, is it from me while inputting data in the form?
And why is it only me among my colleagues facing this?

Hi @Nina,

Would you mind sharing with me the xlsform so that i could have a look at my end. You could share them through a private message if you feel that your xlsform should be treated confidentially.

Have a great day!