Having a Loading problem when Cascading question is down to Admin 4

I have designed a form including geographic location information and all was going well with the info going down to Admin 3.
However, once I wanted to add Admin 4, the form is not being loaded, although it is successfully re-deployed.
Can anyone support me in solving the Cascading question?

Welcome to the community @UNICEF_Sector! Have you gone through our community post discussed previously (it should solve your issue):

If you still face issue with your xlsform regarding cascading select, please feel free to share your xlsform with the community. The community would love help you solve your issue. But kindly note to share only your related issue (i.e. only the selected questions) instead of the entire xlsform.

Hi @UNICEF_Sector
In addition to what has been indicated by @Kal_Lam, could you confirm if the list is too long? If so, then I would recommend considering using external CSV files to execute your cascade. Kindly advise so that we help you sort this.


1 Like

Thank you very much both.
This is much appreciated, the issue is solved though.


Could you kindly explain a bit on how you solved the issue. This should be a reference post to those having similar issues in the future.