How to access data that has been stored in the server (as i am unable to view the same from the DATA tab?


on a standalone KoBo we are facing the following issue: The project has X submissions (As shown in Total: X on Summary page), but the Data tab says “you have no data”.

Investigating, when one enters a new submission, that new submission will be shown on Data tab, - only that one which can then be viewed in charts, downloaded etc. All the data from previous period (seems like from longer ago than 30 days) are unaccessible, albeit the indication in Summary page that they are really there.

How can we get all of our data to be shown?

Thank you,

Hi @maric.vladimir,

Could you let us know which server you are using at the moment? Besides, would you mind sharing us the screenshot of the issue you are having.


Hi @Kal_Lam,

thanks for your message. The software is as follows:

mongo 3.4 0a998023eb2d 4 months ago 427MB
kobotoolbox/nginx latest 0b73b2eaea00 4 months ago 641MB
kobotoolbox/enketo-express-extra-widgets 1.77.0-jnm-grunt-workaround ab42c120b286 4 months ago 1.59GB
kobotoolbox/kpi 2.019.23 aa9cd9bc7b21 5 months ago 1.51GB
kobotoolbox/kobocat 2.019.22 b4c8c3e6f89c 5 months ago 1.48GB
nginx 1.15-alpine dd025cdfe837 5 months ago 16.1MB
certbot/certbot latest 4bdc1514009b 7 months ago 113MB
mdillon/postgis 9.5 a9a97c2d2458 7 months ago 622MB
redis 3.2 87856cc39862 12 months ago 76MB

Here are the screenshots of the Summary and Data tab, as well as downloaded data in Excel… obviously there are 3 submissions, but only one shows.



This one is also quite telling… “1-3 of 3 results” - but only one row?

Hi @maric.vladimir,

Maybe MongoDB is out-of-sync with PostgreSQL.
Can you try to run this command within kobocat container:
./ sync_mongo --all . It can be long if you have lots of submissions in your DB.

BTW, Your versions do not seem to be up-to-date. You may want to update to latest versions of master branch.

1 Like

Hi @nolive,

thanks for the suggestion. It actually runs quite quickly, listing surveys and “Instance count” of each is some number, while “Mongo count” seems to be 0 for all.

Summary at the end:
Total # of forms out of sync: 284
Total # of records to remongo: 33048

It does not seem to rectify the situation, though. What else can we try?

Do you think doing an upgrade will help solve this problem? Should we do it by
kobo-install $ -u


1 Like

You can also try ./ sync_mongo -r -a. It will force to rewrite all the instances in MongoDB (even the existing ones)

If it still doesn’t work, I would do the upgrade after that.

1 Like

That will do the same as ./ remongo, right?

I did a remongo and the issue is solved, thank you.

Regarding the upgrade, is it not that a big one is coming, where kf and kc databases will be split?

Is the --upgrade the correct way of performing the upgrade?

Best, Vladimir

Yep it’s the same as ./ remongo.

Nope, it’s not the big one.
Exact. python --upgrade is the correct way. Don’t forget to stop the containers first and start them after the upgrade.

1 Like