How to force in the decimal type will give a ZERO (0)number in the result?

How to force in the decimal type will give a ZERO (0)number in the result ?, i tried to use the default Value to 0, but the result is still Empty, not show the number of 0
(in Line/row 17,18, 23,24 29,30 35,36)

thank you in advance,



1 Like

@decysophan, having a separate post for a different issue is always good. This helps the users to make appropriate searches for issues that they are facing. I thus created a new topic for this issue.

I made a quick test with your issue for both the integer and decimal question types.

Made a sample collection and could see the results on the DATA>Table View:

HI Kal,

thank you, i just made same as your instruction , same result ,with empty result. you can take a look the XLS Files in google drive through this Link

This is one File with the previuous Question about Coalesce.

Thank you Kal

@decysophan, would you mind sharing the RELEVANT PART of your XLSForm with the community? You should now be able to upload the XLSForm to the community. If you have issues, please refresh the page.

1 Like

Dear Kal,
Thank you

here is The Files

FORMULA SRPI Ed4.xlsx (19.5 KB)

@decysophan, could you kindly mention one question about which the default value is not working as expected? I could then try on the same instead of having a look at your entire XLSForm. This should save the testing time of the community.


Book1-TEST.xlsx (12.7 KB)

Thank you Kal

@decysophan, seems like you are trying to have a value of 0 for a skipped question. Did I get that correct?

Dear Kal…

yes you are right, in the end there are some of formula that need this value .

thank you kal

@decysophan, you cannot achieve this for a skipped question. Maybe you must do this in a post-processing phase (when managing your data).

The calculations will only process if you pass the question visually in your data entry screen. As you skip questions, the values do not get recorded as needed.