How to return the top of form automacally after submitting a response?

My setting
-Online only (multiple soumissions)
-grid theme

Hello dear
thank you for the work you do to help the maximum number of people make the most of Kobotoolbox ’s features.

Today I have a problem to submit to you. I designed my form on kobotoolbox, and I am now testing it before deploying it.

After submitting a response,a blank form is charged but the view stay at the end of form .So i am always scrolling up to add new response. To do so is an onerous task if i want someone else to fill form with multiple submissions.

Please help me to solve my problem with current setting.

NB: I have already tested the "online only (single submission) " that allows return url (i’ve configured the form link).
But there is always a latent time to charge the form. It isn’t soft for me.

Welcome to the community, @ing_kiper2! Could you kindly share with us a screenshot so that we could understand your issue pictorially?

@Kal_Lam thanks for your quick response

on picture 1 (pic1) it is the message that says that submission was successful.

on picture 2 (pic2) it is just after the validation; the questionnaire is empty again but it stays at the bottom. So I have to go back up and fill out a chart.


So you mean the system should take you at the top where the input is empty automatically?

Yes exactly
I want the system to bring me back to the first question on the form.

Maybe you could use the required_message to solve your issue as outlined in the post discussed previously:

@Kal_Lam thank you for taking charge of my request.

But my problem is not solved yet.

I do not see how customizing an error message can allow me to return to the first question on the form.

What I would need, for example, is a button that allows me to move (up) – Is that possible?

Maybe this should help you get a red alert to the question which should be filled up.

I see we did not understand each other well.

I am not trying to fill in an empty field but I am trying to fill out another form.

To complete another form I must start at the beginning of the form.
And this is where the problem arises because when I finish a form I am not taken directly to the beginning of the questionnaire, but I stay at the end. And so I am forced to go back up manually to start again the entry of a new file.

I’m sharing the input link so you can see better. Try to enter two responses, you will see better what I’m talking about. Enketo Express for KoBo Toolbox

Thanks again for the support.

@ing_kiper2, would you mind sharing with us a short video clip to demonstrate your issue? Maybe sharing the same through the Dropbox. This should help us visualize your issue much better.

Hi @Kal_Lam
OK no problem
please see the video below: Dropbox - video for support_kipreh2.mp4 - Simplify your life

parts of the video:

00: 06- I finish a form

00: 13- I go back to the top to enter a new answer
(what I want to make automatic)

00: 25- I enter a new answer

1 Like

Hi @Kal_Lam
I haven’t had any feedback since yesterday. I did make a video to explain the problem in my previous post. Can you take a look? Thank you in advance !!!

@ing_kiper2, will get back to you soon with this.

@ing_kiper2, would you mind sharing with me your xlsform so that I could have a closer look at it (by uploading the same in my account) to see if the same happens at my end too.

ok please check your private messaging

@ing_kiper2, I quickly checked the same at my end (by filling up all the dummy details) and I get a new screen when submitting the filled up form to the server. FYI, this is the new screen I get after I submit the data to the server:

Would you mind trying it in a different browser or with a different PC to see if this is still on?

It must be due to the single page parameter (“grid theme” without multipage) because with the multipage mode that you used the problem does not arise.

So I just have to change the display settings by favoring a multi-page mode. I think my problem is solved now.

thanks again @Kal_Lam

1 Like

Thank you for confirming @ing_kiper2!