I am having this very same issue (Form list download failed)

I am having this very same issue.

I have checked my device time settings,
Double-checked the URL
Used online form validator, with no error
Tried multiple versions from GitHub
Tried different server URL
Uninstalled and reinstalled the app.

None of above is working. What should I do?

Collect cant reach server kttps://kf.kobotoolbox.org…

Welcome to the community, @afondo4! Could you also share with the community a screenshot of your issue so that we understand it pictorially and be able to troubleshoot it?

Problem solved @Kal_Lam !

The issue is lying on a misleading address found on the Kobo instruction page and Android device configuration page (I strongly believe this might not be the case for everybody). The right and updated server address is https://kc.kobotoolbox.org, not https://kf.kobotoolbox.org.

Whoever goes through this issue, please try this solution, it may work.

1 Like

@afondo4, kindly please also be informed that the typo has also been resolved (in the server side):