I cannot deploy my survey

Hi all, I completed the first draft of my questionnaire. However when I try to deploy it I get the error message in the screenshot bellow image

There is no element like that in the questionnaire. Nevertheless, following some instructions I found in the community forum I tried to downlod the xls file but when I click on the relevant option nothing happens: nothing is downloaded.

I am really stuck - can you please help?

Thanks in advance

Dr Theo Papadopoulos


If this is in the type column, remove the underline after select_one: select_one nk93m14

1 Like

Hi I think I have managed to rsolve this problem and deployed my survey for piloting.


1 Like

Thank you for confirming, @thetapibath. You could always validate your xlsform with this online validator. This online validator should help you identify the syntax errors that are present within your xlsform.

Just to help others who may experience the same problem:

The issue was a variable name and a variable label in one of the Likert-scale questions. Basically (from what I understand) a label and a name is needed in each of this type of questions. See the screenshot below. FYI - I discoved this after I cloned the questionnaire and then I started re-introducing the questions one by one. Thank you KAL-LAM for your support. image

1 Like

Glad to know that your issue has been solved.