I can't edit my data from the (form/data/table)

I have a form where it pulls data over like 70% of the form entries, now it’s all working fine, as I pull data and send the entry it goes to the data as usual.
The thing here as I want to edit any entry as an admin, It couldn’t be edited (not all data), I mean any data that has been pulled can’t be edited from here.

I can change the values and edit them but when I press send it doesn’t save any made changes.
But when I edit any field that has not been pulled before when it first was filled and sent it can be changed normally

The problem here that any pulled data can’t be changed later from (form\data\table)
Is there anyway I can change that ?

Do you mean you are not able to edit a submission that has already been edited once? Would you also mind letting us know the server you are using? In addition also please help us better understand your issue by providing us the steps that we could follow to replicate the issue at our end.

Yes exactly, I dont think I can explain more, I’ve stated it all
and yes exactly as you mention I can’t edit any submissions at all “just the pulled data”
for example date of birth is not pulled , so I can edit it after submission, but any other pulled data during the survey filling, it won’t just accept any editing after the submission

Would you mind sharing us the following information through a private message:

  • Username
  • Project name
  • Server
  • _id if it’s an issue with a specific case

Hi @dwaimah,

I could edit the same through DATA>Table.

Nothing is changed here, I mean any “pulled data” can’t be changed

Could you share with me the _id so that i could check it out at my end.

Here’s the ID for some sample field that can’t be changed

The _id should be something like this:


I got your point but this id is only pointing to a special case
the thing that it happening to all cases its just not all fields in the form has been pulled
so just try to any case lets say the first case, then go the field i showed you, this field for example is being pulled, if u change anything in that field wont be changed after submitting
take this field for example

Could you share the same by translating the page to English. At the moment not able to understand the text of your screenshot.

I have added English translation
you just open the case and search in your browser for “Orphan lives in this house since”
thats the field

Hi @dwaimah,

Recently we had an Enketo update issue. The downgrade of Enketo from 2.6.0 to 2.5.6 should solve your issue. For details, please feel free to go through the announcement:

Could you kindly confirm if this should solve your issue.

I got your point there, but I did not find how to downgrade my enketo to 2.5.6
I can’t find it in the announcement.

You need not worry, it has already been downgraded in both our servers (OCHA as well as HHI). You will just need to check your survey project with the issue to see if the issue is still on. If the issue is still on then we need to understand that your issue was not related to Enketo upgrade and we will have to troubleshoot it again.

1 Like

Well the issue is still on, not been solved, I think that it is been like this since before the update to enketo, I think it’s handling the edit form thing from data - table as the form is being filled for the first time, so the pull data function will still be working, no matter what you edit won’t be accepted as the pull data will submit the final result. will it be solved ever ?

Hi @dwaimah,

Would you mind sharing with the community a video capture of the issue. Maybe we should be able to track it down easily then.

I have the same problem