I don't reach to encrypt my form... why?

1. What is the problem? Be very detailed.
I try to encrypt my form, but I don’t reach!
I don’t see the text “encrypted” next to my form name.

I’m using KoboToolbox

3. What you have you tried to fix the problem?
I follow step by step Encrypting Forms — KoBoToolbox documentation? , also to generate public and private key

4. What steps can we take to reproduce the problem?
I think it’s not a problem, but something I’m doing wrong!!

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
abBeRJYzmuG3EU5qH6eTsW.xlsx (14.9 KB)

Thanks a lot!!

Welcome to the community, @aortegon! Kindly please be informed that users should be able to encrypt their data at the project level (in your user account) and not with the display of your questions in the xlsform. Once a user encrypts his/her project the submissions is not viewable in the user’s user account even through you are the admin. Users should only be able to access them after decrypting it through the ODK Briefcase.

1 Like

Thanks @Kal_Lam !!

Yes, of course, I try to encrypt following directions in the link above.
As you can see in the attached xlsx, I’ve created and pasted the public key and so on;
I know that data will only be accesible after decripting using ODK Briedcase… but it will be the next problem: now, my problem is that I don’t reach to encrypt; after, I’ll face the decripting situation.


@aortegon, I just tested your xlsform and I could encrypted them very well at my user account. Sorry I could not clearly understand your last sentence…

1 Like

Can you encrypt it??
This is what I see; the text “encrypted” is not as expexted

My last sentence is only to explain that until the moment, I have not reach to encrypt; if I reach to do, I’ll see how is to decrypt, because I have not some experience on that.

Thanks @Kal_Lam !!

There are basically two approaches to check if your encryption is working as expected:

  • From the Collect android app, once you have completed colleting the form and then you press save, you should not be able to edit it any more. You should get a message This form cannot be edited once it has been marked as finalized. It may be encrypted.
  • From your user account, you could try viewing your DATA>Table. You should see nothing. Besides, if you even download your dataset as an xls format you should see a blank dataset.
1 Like

Ok, I’ll try what you says.
I expect the text “encrypt” just like the doc explain “Once deployed you should see a label with the text “encrypted” next to your form name” :wink:

So, first at all, I go to complet somes instances of the form, and I’ll see the data table…

1 Like

Sorry, with ODK Collect, I don’t see anything.
Must I use Collect, or Kobocollect?

After using KoboCollect and fill 3 times the form I see

…so, I must say my form is encrypted!!! Very well, thanks so much!!

Whats about the expected text “encrypted” next to the form name?? Where it’s expected to see it??

Now, I’ll try to decrypt to be sure the I can complet the process.

1 Like

Sorry… I face now the decrypting problem!!
If I must to generate another topic, please let me know.

If I use, as explained at Encrypting Forms — KoBoToolbox documentation?
the " Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files 6", ODK-Briefcase don’t open. I must use “…Files 7”, then, ODK-Briefcase starts.
[Also, let me know that the link there Java download site dont works]

Following step by step the instructions, I obtain

Whats I’m doing wrong??

From the error message, I obtain:

Export has started
Can’t export submission uuid601cdcf7-3709-4ff9-9b14-bff9eb6445a4 of form ID abBeRJYzmuG3EU5qH6eTsW. Cause: ParseError at [row,col]:[1,286]
Message: El atributo “xmlns” ya se ha especificado para el elemento “n0:data”.
Can’t export submission uuid81f6d7b1-7c76-469a-9008-79a3b59e2a24 of form ID abBeRJYzmuG3EU5qH6eTsW. Cause: ParseError at [row,col]:[1,286]
Message: El atributo “xmlns” ya se ha especificado para el elemento “n0:data”.
Can’t export submission uuid96cfc605-67a3-4915-bb8b-3a2c0ef80f53 of form ID abBeRJYzmuG3EU5qH6eTsW. Cause: ParseError at [row,col]:[1,286]
Message: El atributo “xmlns” ya se ha especificado para el elemento “n0:data”.
Can’t export submission uuide08a9416-910e-4d09-b20b-4de58f1ed5d5 of form ID abBeRJYzmuG3EU5qH6eTsW. Cause: ParseError at [row,col]:[1,286]
Message: El atributo “xmlns” ya se ha especificado para el elemento “n0:data”.

And, If I try to edit some data, I don’t obtain the message you says, but
…perhaps it indicates some useful…

No need to more help!
Thanks a lot, finally, I have success also decrypting!!

The problem was avoided when I have edited both, the public and private key, to eliminate in its the line-feeds (carriage-return). By doing this, process of decrypting have finalized with success.

Thanks a lot for all. I apologize for the inconvenients!! :wink:

1 Like

Glad to know it worked for you.

I’m having the same error. How did you eliminate the line-feeds(carriage-return?

Hi @warrenmxt
Simply, you must edit the public and private key files (with note pad ++ , for example).
Placing the cursor at the end of each line, press del, and it will delete the line -feed of this line. Repeat the operation with each line, and remember you must edit both, the public and private key files. Ok?

1 Like

Thanks. Let me try this out.

1 Like

I’m still getting the same decryption error. I followed all the instruction, encryption is successful but decryption is the issue now…

Well @warrenmxt , encryption is jet reached, congratulations!
To decrypt your data: what’s version of Suitcase are you using?
If you are using latest version, v1.18.0, obtain and use v1.15.0. @Kal_Lam says me that for decription issues, this version ir more secure.

If it’s fail even with v1.15.0, then consider you can have some instances causing the problem; if there are only trying instances, consider elimnates it’s, and generate other news intances. It will work!!

Good luck!!

1 Like

Thanks alot @aortegon. Decryption has worked with v1.15.0 :slight_smile:


fantastic!!! It’s the better new to take the week-end!! :grinning: :grinning: :wink:

1 Like

Indeed. Thanks for the assist. :grin:

1 Like