I uploaded the xsl version and keep getting the same error

Hi, I am having the same challenges.

I uploaded the xsl version and keep getting the same feedback, even though the file name is correct. When you say delete the media files from your project, what do you mean please? Would appreciate some help on this

Welcome to the community, @Candy! Maybe you will need to share a screenshot of your issue with the community so that the community should also be able to understand your issue pictorially.


@Candy, the issue has been addressed on our side.

Feel free to reach us back if you should still experience this issue.


I am still seeing the same error. I’ve tried deleting and reattaching but I keep getting the same message


could I get some help on this please? I have a team of data collectors on standby

Hi Candy, have you applied the quick fix mentioned above (delete csv file from Settings/Media, deploy form afresh while maybe ignoring the a warning, upload csv file and finally deploy form again)? Just thinking that while the bug has been fixed by now, it might be necessary to apply the quick fix once to get rid of some remains.

If this doesn’t help, you have to share with the community how your form is defined regarding the access to that csv file. Maybe it is just the wrong name or something like this?

1 Like

Hi York,

I tried the quick fix method but it didn’t work. I have doubled check the name in the tool and the name of the file and it’s correct. I can share the xsl tool if necessary

@Candy, could you kindly share your CSV file with the community? I assume the issue is in your CSV file format.

iapdata.csv (577.3 KB)
Here is the file


I have shared the file with you.

@Candy, I did find some CSV header naming issues in your CSV file. FYR …

1Name of child
8 Age
50% SE Payment Farmer

  • Header starting with a number. Try to avoid such a practice. Instead, use alphabets for the same.
  • Space in your header name. The header name should not have space.
  • Use of special characters (%). Avoid using such special characters in your header name.

Fix these issues, and it should solve your issue. One more, if the values for any headers are empty, try removing them from the CSV file.

Thank you, I followed the steps and it worked!