Information from a repeat group question not being able to edit

Dear friends,
I have a questionnaire that allow you to enter the family members details in repeated groups according to family size, and i am using enketo,

After somedays, the questionnaire does not allow the field workers to adjust the family members details after filling and saving as draft. so they can adjust all the assessment except the family members details, and when they sent to the server, the family members details were missed. Is there any interpretation? Or suggestion?

Could you kindly share with us a sample of the screenshot of the issue you are facing. This should help us better understand your issue.

Dear
The field staff already filled the questionnaire and saved it as draft. Later, they wanted to check out the data and review it in order to send it to the server but when they entered again to the already saved questionnaires, they could not reach the repeated groups as shown in the photos below

you can see in the two uploaded photos that family size are already filled before saving the questionnaire as a draft, and when they came back, they found the response is still existed but they can’t enter to the repeated groups which contains the details of the family members.

when i also downloaded the excel sheet., i found that the questionnaires that were filled and saved as draft have no family members details even though the family size question is already filled and the groups as well since the questionnaire can not be sent without begin totally filled. while the rest questionnaires that were submitted directly without saving as draft, have reached me with no missing data.

As you can see below, in the first photo the HH information are gathered and the family size is filled. the highlighted names have no family members in the second photo below because they were saved as draft before being sent.

The issues here that the questionnaire was going effectively in the first day of the month, and the problem is new on the same file without we made any change.

1 Like

@Kal_Lam @stephanealoo
Please can any of you help? it is an urgent matter of time.

So, seems like you have the following in your xlsform:

  • A variable that captures the total number of family members.
  • Repeat group question.
  • Repeat group question is controlled by a repeat_count.

Kindly please correct me if i understood you wrongly.

Hi @mohammedrezeq

I noticed that your repeat groups are dependent on the 1.27 i.e. size of household. Could you try editing this and see if it allows the entry of data within the repeat groups?

Troubleshooting hint: I need to verify whether this is an issue with reading the constraint on the number of repeats or the actual entry of data in the repeat group.

Could you send us a link to the form so that we try this on our end, i.e. entering the data on the draft and the non-draft approach.

From your explanation, it actually seems that the draft seems to be submitting data even when they are required that is why you are having blank data for those.

Regards
Stephane

1 Like

Yes dear, the field workers enter the number of family size, then a repeated groups of question are opened and by the repeat_count of the family size that was filled by the field workers.

Hi @stephanealoo, i did not captured what you mentioned. But here is the link of the questionnaire.
Here is the link of the questionnaire.

Hi @mohammedrezeq,

This should be a bug with the recent release of the Enketo which should be fixed with the next release of the Enketo. Will notify you when the same is fixed with the next release.

Hi @mohammedrezeq,

Kindly please be informed that the recent release of the KoBoToolbox which also includes the most recent version of Enketo (i.e. 2.6.0) should solve your issue.

For details, please feel free to go through the release announcement:

1 Like

Please @Kal_Lam, let me know what should i do to run the questionnaire correctly? should i deploy it again? make another link? or what?

Didn’t get you correctly. Do you mean your issue is still on?

Yes @Kal_Lam

@Kal_Lam
i made new link to seek if it is working in a different project. i tried to send directly and it works, but i tried to save another questionnaire as a draft. and when i wanted to retrieve it (open it again), the following message appeared and i could not open it.

Note, the link will only work once. If you try to use the same link more than once it should not work.

Did not get it, sorry…

i mean, i uploaded the form again and made two questionnaire, one sent directly and the other saved as a draft, then when i went to send it. this messages has appeared

Maybe you should be able to describe us in a much better way if you could share with us a video of your issue.

The Enketo message Cannot read property 't' of undefined should have been fixed today by Release Notes - Enketo - version 2.5.6 (downgrade).

I am hopeful that the repeating group problem should also be fixed, even in the older 2.5.6 version.

I think the our deployments went something like this:

  1. Enketo 2.3.10, deployed in August, had no problems with repeating groups;
  2. Enketo 2.5.4, deployed on 22 December 2020, introduced an issue with repeating groups;
  3. Enketo 2.5.6 (or 2.5.5) fixed the repeating group issue, but we did not deploy it, instead skipping to…
  4. Enketo 2.6.0, deployed on 30/31 December 2020, which included the fix for repeating groups but broke many calculations (leading to the Cannot read property 't' of undefined message).

We deployed Enketo 2.5.6 today, which should give you the fix for repeating groups without breaking any calculations.

2 Likes