Intermittent "import failed" error when importing XLSform

Hi there, using the server - just “New” to create a new project, then selected “Upload an XLS Form”

However, when I a) drag and drop an XLSForm or b) click to browse and select the XLSForm, I intermittently get the error below.

The XLSForm is one that is currently in use fine on another server (i.e. I know it validates fine).
I have tried several times, sometimes I get this error and other times I don’t (i.e. can create the project fine).
Is it possible that maybe some machines have diff config? or???

Anyway will leave it to the Support team to decide what action to take - no further action needed from my end as I have managed to create my project fine in the end - just thought you should know.


Import Failed!
Name:  [XLSform name]
ProgrammingError:  column kpi_asset.editors_can_change_permissions does not exist
LINE 1: ...
"kpi_asset"... ^

@nat, thank you for reporting this to the community! I agree with you. I too see this message on and off but at the end I see that users are still able to upload the xlsform successfully. Will get you back if there is anything we could do to fix this up.

Hello @nat,
We encountered the same (after last update?), but only temporarily, afterward same upload worked fine. All on OCHA server. So, doesn’t seem to be a differnt config issue.
Kind regards

1 Like

Thanks @nat and @wroos for the information

This is noted.

As @Kal_Lam mentioned, we have documented this with the developers and we are looking at it.



@nat, @wroos, kindly please be informed that this was an issue at our end which has been solved now. Thank you for bringing this to our attention. Expecting the same in the upcoming days.