Invalid status code on head request

Dear friends
i can not submit my form to Kobotoolbox it gives the massage (invalid status code on head request).
can any one help me in this regard?
thanks in advance

Hi @adilmansour,

Welcome to the community! Would you mind sharing us a screenshot of the General Settings>Server from your KoBoCollect android app. This should help us identify your issue.

Have a great day!

1 Like

Thank you Dear @Kal_Lam for the reply,
the problem solved, the url of google sheet was used in setting of the form, finally i found the issue and the issue was solved.
thanks again for your interest in solution.

1 Like

Hi @adilmansour,

Thank you for sharing your solution with the entire community and making the community forum rich with documentations related to KoBoToolbox solutions.

Have a great day!

1 Like

I have the same problem. How can I be helped

Welcome to the community @Kibirige! Would you mind explaining your issue so that we could help you out solve it. Would appreciate if you could share a screenshot of the error message too.

Its showing invalid status code on head request

A screenshot of the same would be helpful to better understand your issue @Kibirige!

That is the problem

That is the problem

OK. Could you kindly share with us the screenshot of the General Settings>Server. This should also give us a clue to your issue.

Its there

OK, would you mind trying it with the following settings:






Sir its still the same error

OK, could you share with me the screenshot of your KoBoCollect android app (Delete Saved Form>BLANK FORMS)?

Its here

Well everything is OK till here. Would you mind checking your KoBoToolbox server and see if the survey form is still present (not archived/deleted)?

What about uninstalling and installing again the kobo collect app again

The error that indicates that you have a web proxy could be pointing to two possible things:

  1. The internet connection you have requires that you log in to get access. Could you change the internet connection and see if it sorts out the issue.
  2. Could you try login into the server on a browser using the same credentials and internet connection so that we see if you get the same issue?


1 Like

I need your help, I have a form for selected items, but each selected item has to input 5 different data categories , how do I put that form