Is there any way to restore an older version of an undeployed form?

I was working on a 150 questionnaire, and suddenly all the questions disappear and all the groups are empty. I don’t know what wrong button did I click and also shows a server 500 error.
I there a way to restore the form I was working on.

Welcome to the community, @vaishakhi! Did you ever deploy your survey project that had issues?

Nope. It is an undeployed project

@vaishakhi, sorry to inform you that if its not deployed it’s not possible to retrieve that survey project. However, would you mind sharing with us the details on what exactly happened, a screenshot of how it sees at the moment so that we could create a GitHub issue for the same. It would also be helpful if you could also share with us the your username and also the server your user account is in (through a private message).

How do I send a private message here? email?

@vaishakhi, you could send me a private message as outlined in the post discussed previously:

@vaishakhi, I confirm that the groups are empty:

Could you kindly let us know more about how this happened. Maybe that would help us investigate more on this.

We built the questionnaire on Kobo, with around 150 questions divided into 5 groups.
And then we went ahead to add languages. Defined the default language and then added one. At first, language wouldn’t be added. And then after the third attempt, we were able to add another language. After adding the language, when we come back to the questionnaire to download the excel form of the questionnaire, we get ‘serve error 500’. And, the questions inside the groups disappear.
We tried making a new questionnaire and faced the same issue.

@vaishakhi, thank you for providing a detailed explanation. This should be very helpful for our team.

1 Like

Hi @vaishakhi , I’m one of the developers from KoBo and I’m looking into this issue. Hopefully if we find the culprit we can stop this from happening again!

When you say

We tried making a new questionnaire and faced the same issue.

what exactly did this entail? I’ve tried to reproduce your issue on your account by:

  1. Create a form from scratch
  2. Add select_one/many questions
  3. Add them to groups
  4. Save and add a default translation

and received no errors or disappearing questions. Is this similar to what you have done? If you’ve tried to recreate the survey via XLSForm and uploaded it could you please share it with us? If not, could you attempt to do so?



Along with a default translation, we added one more language. The questions disappeared after we added a new language.
Didn’t use XLSForm. Used the Kobotool itself to build the form.

After working hours on it and the questions disappearing, we gave up on it. And build the same form on the research server.

After this, I tried making a short 5 question questionnaire, without a group and added a new language along with the default one, I didn’t face any issue there.

1 Like

Hi @vaishakhi, sorry that you had this problem. I understand it’s frustrating when things go wrong unexpectedly, but I was able to recover a saved draft of your form. The specific version that I restored is the one before the language was changed from “Hindi” to “English”, as it was the last non-corrupted asset.

As to what had happened, since we couldn’t reproduce it I think it’s safe to say there was a browser or network glitch (not from our end).

I took the liberty of uploading the recovered draft to the owner’s account and gave your account the “Manage Asset” permission it had before. In case you want it, here’s the recovered XLSForm:

Recovered draft of SEWA Sarthak Study - May 2021.xlsx (17.8 KB)

So to answer your original question and the topic of this thread: yes, there is a way to restore an older version of an undeployed form–though not through the UI. It’s done through our API which is outlined in this form post (asking the same question): Recover draft version of form. We should try to reference this post next time someone asks this :slight_smile:

1 Like

Thank you very much. Although now the new project on the research server is ready and functional. But will keep this handy in case we come across such an issue again.

1 Like