Issue in Choice Filter for Others

We are facing problem for Others Specify in Choice Filter. We have 2 Question, Q2 will show the options coded in the Q1, but in Q1 there is Others Specify and Q2 choice list has Other List called from Q1-Others Text. But when we select Others in Q1 then the Screen disappears and go the home screen in Kobo Collect App. Earlier this issue was not there but we are facing this issue. Dont know why is there any update going on? Kindly help us its very urgent.
Also sharing a sample form.Test.xlsx (18.3 KB)

Could you share with us a screenshot of the issue you are having?

We are not getting any error. Its just comes out of the Form and goes to Home Screen. So, how can i share the screen shot of that. We are using Kobo Collect v1.30.1

You can check by selecting Others in Q1 it will get out of the form to the home screen I have shared the sample form. Will it take time for the issue to get resolved.

Yes, I could replicate that and when you do not select other it works just fine. Maybe the upcoming release could address this if possible @Xiphware?

Maybe this one should be more simple for testing:

Test.xlsx (18.0 KB)

OK Hope to get the update done soon as this is a required and necessary option. Earlier versions it was working fine but now its not working. Still any idea by when it will get updated so that we can plan accordingly

@khasaab, which version are you referring to? Was this same xlsform working in that version and stopped in this one? Or, was there any modifications of your xlsform?

We have checked the old deployed forms with the same criteria of others and choice filter its working fine in this version of Kobo App also. I think its the new form we are deploying having a problem not with the Version of Kobo Collect App . Hope it might help to resolve the issue.

Which was the Collect version you were using previously?

We don’t remember the earlier version of Kobo Collect. But in one of our Mobile it is v1.29.3. But i don’t think the issue is with the Kobo Collect Version because our earlier deployed form in the current version v1.30.1 is working fine, its only that any new forms we are deploying having this problem.
One more thing we have noticed that we have today again deployed the test form and when we tried to again open the saved form which was disappear in v1.29.3 Version and tried to directly jump to BQ1c question it gives this error. (Hope this screenshot helps)

But in v1.30.1 version it directly disappear again without any error when we tried to jump to bq1c Question.

Maybe you will need to double check the changes you made from your earlier deployed version which you say works while the current version does not work.

Yes we have checked it properly it is the same case of showing others text in the next question and with choice filter. May be something has been updated in the portal while deploying form now

But maybe you did not have the other text that links up dynamically under the choices tab.

I am sharing you the part of the earlier deployed form which is working in the current version too. But it was deployed earlier means few months ago…
Tyre - Test.xlsx (14.1 KB)
If you see its the same filter which is followed but working. Thats why i told it is something with the new deployment done in the portal.

So you mean this xlsform works?

No i mean to say this xls form is working because it was deployed few months ago but if i deployed this same xlsform now then having the same issue.

1 Like

Is there any update on this issue.

Sorry, we don’t have an update for this but will get back to you when we do have.

Hi @khasaab, would you mind please sharing the following with me a private message so that I can take a look:

  • server (OCHA/HHI)
  • username
  • project name
1 Like

Hi @khasaab, as discussed privately, for some reason you need to ensure that you either have more than just the default translation or that you specify the language of the form, i.e.: change column headers from label to label::English (en), etc.

1 Like

Done! :+1: