Issue on creating environment

Hi there

I have configured a t3.xlarge( 4 vCPUs and 16 GB RAM) ubuntu 18.04 server but still we are stuck at the point when kobo tools gets the env ready.

We have installed all the service below:

  • Redis-server

  • mongodb

  • postgresql

  • nginx

  • docker

  • docker-compose

We have also tried running the sudo --upgrade command but it shows the same result. Logs also look fine there, although I have attached below. These were after the third run.

Please help us out here.

Thank you

If you are using then you don’t need to install redis/postgres/mongo/nginx separately unless you want to.

If kobo is getting stuck at the last stage, your domain and the subdomains are not available/reachable from the kobo server.

1 Like

What logs have you checked?

When the last step hangs, do Ctrl+C. Then type docker ps to see if all containers are up. If some of them are stopped or restarting, check the docker logs of that container.

If all the containers are up and running, your website should be running as well.

1 Like

Yes, I tried that one of my colleague used the setting and it worked :slight_smile:
thank man for the help

1 Like