Issue when deploying link to form in email

I just sent an email out to a group of users with a link to a KoBo form (two buttons that went to the same link and one text link. Oddly, while most of the users could click the link and get to the page, at least ~10 users complained that the links were broken. When tested on both mobile and desktop, the links in the email worked. When an email was forwarded to me from one of these users, the links in the email worked on desktop, but not on mobile. When I click any of the links in the email via mobile (iPhone with Gmail), the form appears to load, but it seems to keep loading and I get a message that says redirecting.

Any thoughts would be helpful.!
Below is the result of loading the link:

Hi @vickiedenicola
I noticed you mention that the link is not working on the phone. Can you confirm the browsers they are using on the phones that cause the problem? Let them try refreshing their browsers or using a more updated browser and they could stat with chrome.


@stephanealoo, I had one of the users forward the message and when I try to click the link on my iPhone using Gmail and trying both Chrome and Safari as the default browser, the outcome is the same (phone browsers are updated):

Ever so oddly, it works opening the same email link on a Mac using Chrome and Gmail. It appears to only impact some users, because some have successfully completed the form. I don’t see anything odd about the collection of email addresses of users who had issues. Any additional thoughts? Interestingly, the email tested fine for multiple people.

Let me know if you need anything else to help troubleshoot.


Hi @vickiedenicola,

Would you mind sharing with us your url link (both the one you say is working and the one you say is not working for the same project) through a private message. Would like to test it at our end.

Have a great day!

Not at all. Could I forward the email to you — the one that is not working?

And separately I will send the url.

Interestingly it works fine if the person running the project replies to the user with the problem and directly pastes it in the body of the email.

Hi @vickiedenicola,

Sure! Try sending it through a private message.

Have a great day!

Sorry for the basic question … how do I private message? :slight_smile:

Hi @vickiedenicola,

Please be informed that i could open the survey link that you shared. However i did not find the email link that was broken (on your tablets).

As a workaround i would advise you to do the following to see the difference manually:

  • Copy the broken link that you get from your tablet/mobile and paste it in a notepad or similar application.
  • Check the URL with the one that is OK (manually, alphabet by alphabet). Generally if there is a typo in the same it should cause issues.
  • Last but not the least, try updating your browser. Sometimes outdated browsers should also cause you this sort of an issue.

Please reach out and let us know what happens.

Have a great day!

1 Like