Issue with select_many question

I don’t think I am the first one to have this issue and I really need help. Whenever I try to save and deploy the survey my options change. I have redone this 3 times and the problem persists. Could it be a problem with the XML value?

I have tried changing the XML values and I have tried cloning and still the problem persists. I don’t know what to do. Any help would be great.

Hi @el_nino_palau

Can you share a screenshot of the changed XML values too?

I think you need to assign unique XML values for unique choices in the formbuilder, but let us test this theory first.

1 Like

I changed the XML Values for each individual question but as I went back to screenshot I see that the problem is the same and the Options as well as the XML Values are the same for all my select_many questions.


The best workaround is that you delete one of your questions and create the question from scratch, not by cloning another question.

Seems like cloned questions take the same choice_list, and this is a known bug.


Would you mind not posting your same issue twice to the community, please, see Issue with choices question - #12 by matu?

1 Like

@el_nino_palau, maybe try downloading your form as XLSForm and then try checking them if the choices are OK. You could solve your issue by doing the same and then redeploying your changes on the server.