Issues with Enketo Grid Theme - Arabic

Hello everyone,
I am having trouble with the layout of my grid-themed survey in Enketo. For the English version everything is working absolutely fine. But for the Arabic version, the visualisation seems to have an issue (see picture)

As you can see the text starts too high, and thus there is a slight overlap into the lines of the previous row, and the box does not have the closing line at the bottom.

Anyone any idea how to fix this, or if it’s a bug in Enketo?

Thank you very much in advance.

Hi @Arqaam,

Would you mind sharing the English version too so that we could have a comparative look at it. Besides, would you mind letting us know the browser you are using currently. Would you also mind changing the browser you are currently using to Chrome, Firefox or Edge and see if the issue solves.

Have a great day!

Hi @Kal_Lam,
thanks for your swift response!
Here it is for the English version:

I am using the latest version of Firefox, and I just tested it in Chrome too. Same issue.

Thanks!

Hi @Arqaam,

Would you mind sharing your xlsform so that we could have a closer look at it (at our end). If you feel it should be treated confidentially you could share it through the private message.

Have a great day!

Hi @Arqaam,

Is this setting OK. Tested it at my end:

Have a great day!

Hi @Kal_Lam,
you still have the same issue I showed in the first screenshot. When you look at the box with the second begin_group (orange heading). You can still see that you have the first Arabic answer difficult to read, as its on top of the like of the heading box and there is still no closing line for that box.

So, nothing changed here.

Hi @Arqaam,

I have faced the same previously and as I think the issue is due to the period (.) at the beginning of the question “.هل نفذت اي من العناصر التالية”. try to delete it and see what happen.
If you could share your form with me, I could help you with it.
Best,
Yasser

1 Like

Hello @Ysr3322,
well spotted for the period (.). I deleted it, but the issue is still there.

I think its a bug in Enketo, that has the line spacing different for English and Arabic.

Hi @Arqaam,

As I said I face the same issue previously. Although I could fix it, I don’t remember how?
I advise you to remove all punctuations and line breaks.
Could you please share with me only this question as a xls file?
Best,
Yasser

1 Like

Dear @Ysr3322,
here is the file with the one question:
Problem.xlsx (14.2 KB)

Thank you so much for your help!

So it seems this is a bug, and not a problem with forms. For some reason, Grid-theme is not giving as much space in Arabic, than it does in English.