Kobotoolbox installation


I am trying to install Kobotoolbox on my local server Oracle Linux 7 i have installed everything required except for Nginx.

After everything i prepared i run tox -e py36 and it returns with congratulation everything can be run normal.

Now as i followed on the guide in github i run python3 run.py and i follow all the steps and i set my public domain name as the ip address of the server now everything goes on until i reach waiting for enviroment to start and it prompts me with the 600 seconds would you like to wait and i answer yes couple of times but nothing happens.

Am i missing something here like is there a full document on installation cause even after i finish the run.py what should i do next ? like how do i later change the configuration like public domain name and is it supposed to be installed in default location as /root/kobo-install am i missing something here?

Thank you.

These are my --logs and --setup logs

Edit i disabled HTTPS now it says :
Launching environment
Port 80 is already open. KoboToolbox can’t start
but i have nothing else started.

Hi @Elie. are you seting up a production server of test server?
Are you running a VM, Did you configure your subdomains in the DNS?
Counter check the above.

Should you need assistance for Production environment I will charge you a small fee

Stephen Oduor

Hi @stephenoduor it is a test server and yes i am running it under a vm, i still dont have a proper domain name for it and i dont think i configured the subdomains in the DNS.

Any idea about the above error port 80 is already open ?

It wont work the way you are doing it

well without any clear documentation or examples i will not be able to install it.