Library questions/answers change when added to a project

Hello, I have created questions on the library where I will busing multiple times. When I open the questions in the library, everything is correct. But once I add these questions to a project, the answers change. The answers usually come up relevant to another question that is in the library. What can possibly be wrong?

Thank you!

Welcome to the community @Momory! Would you mind sharing us a screenshot of the answer that is changing? Kindly please let us know what it looks like and what it should look like.

So the first screen shot is in the project section and the answers changed. The second screenshot is taken from the library which is correct.

So do you mean the issue is when you pull a question from the library to your form builder UI, the choices changes?

Exactly. Tried to build a new form and same thing happened.

Which server (HHI or the OCHA) are you using?

It is HHI.

1 Like

I just tried at my end and did not see the issue. Could you share with me your username through a private message so that i could have a closer look at my end.

Doing that now.

1 Like

Tested your issue in your user account and did not see the issue at my end:

FYI, you could have a look at this project in the draft here:

Could you reset your computer and try it again? You should not be having this problem.

1 Like

Thank you! let me restart the computer and check.


Also try changing your browser. Sometimes it helps! I usually prefer testing it with Chrome or Edge. In your case i tested it through Edge.

1 Like

I am back. Restarted the computer, tried in Chrome and the problem is the same. Anything else that I could try?

Could you list out the exact steps you performed? Maybe you could also attach a small video on how you did so that it would be easy for us to follow your steps and reproduce the issue.

Sending you a video privately.

1 Like

Please do let me know if there is something that might be wrong or something else that I could try. Thank you!

Having a closer look at two of your questions (boxed with red):

I observed that, they both had the same select one options. i.e. select_one hospital for Dubai as shown in the image below:

And select_one hospital for AI Ain as shown in the image below:

For this, i simply downloaded the xlsform for In which hospital in Dubai? and In which hospital in AI Ain?. Try fixing the same in your project library and you should probably not see this error.

Thank you will try doing this!

1 Like