Link to submitted photos has changed! How to create new Link?

so far, submitted photos were accessible via the following methodology:[Username]/attachments/[Form uid]/[Submission uuid]/[NameofFoto].jpg

This was the situation until yesterday. Today I recognize that the methodology has changed to:[Username]/attachments/[Form uid]/[unknown string]/[NameofFoto].jpg

So far so good. Replacing ‘attachment’ with ‘media’ is no deal.
But I cannot anywhere find the information which is replacing the [Submission uuid] to develop the link correctly.
Thank you for your support!

The problem exists for submissions before January 10, 2024.

Newer submissions can be accessed via …/[uuid]/…, by just replacing ‘attachment’ with ‘media’.

The question remains how the older photos can be accessed.

@jps, have you tried the same, making your data public?

@ Kal_Lam Thank you for your suggestion. I’ve tried with public data, the result is the same.

I’ve investigated a bit more as the date of submission turned out not to be an obstacle. My latest findings are the following:

  1. …/media/… and …/attachment/… can be used synonymously.
  2. The problem occurs when records are edited.
    We record the data with kobocollect on site and administrators clean them via Enketo.
    It seems media files are identified by [original uuid]/[NameofFoto].jpg
    But as soon as the record is edited, it gets a new uuid while media-identifier remains at the original uuid.
    Therefore, the problem could be solved if I would be still able to find the [original-uuid] after the update of the record.