Location is not working in Enketo web form

Hi friends,
I’ve deployed a new form for my new project. This time I used the enketo web form instead to kobo collect as there were lot of matrix question. the form is working except the location. pls any one help me to overcome the issue.
Thank you
Amila

1 Like

Hi @amilabandara,

I just made a try at my end with the geopoint questionnaire (gps) and it works smooth. Could you share with us your screenshot so that it would be easy for us to figure out the possible reason on why you maybe having the problem.

1 Like

One thing to check is location services on your device. Turn off WiFi or other internet services on the device and go to Google maps to make sure your current location is correctly identified. You should see a blue dot in the center of your screen.

Note: You may need to download a map while connected to see your location.

2 Likes

Dear Kal_Lam
pls see the screen shot on bellow link

Thank you

Thank you jblackman
I’ll try that way

Hi @amilabandara,

Do you find it working now?

No. the issue is still there .

Hi @amilabandara,

Have you tried this out? Please click to the padlock and then select allow under the location as shown in the figure below.


With this you should be able to select the location from your browser.

1 Like

Hi Kal_Lam,
Thank you very much. now it is working smoothly.

1 Like

Hello All,
Kal_lam ,
i have the same issue now
opening form link on mobile web browser , i cant pick location
any idea , what should i do ?

Welcome back to the community, @omaribilal! Did you try the following:

  • Switched on your device’s GPS
  • Updated your browser to the latest release.
  • Tried out the same with some modern browsers like Chrome, Firefox, Edge etc.

i think there is nothing we can do
i try all this things
changed the appearance of the question typed geopoint
use new browser
check the Location on the mobile
i think it is browser issue on small devices .
so i will leave it

Hello @omaribilal,
Could you share the related part of your form here (download project as xlsform), please?
And tell us what appearance options you tried?

Let us find out more, if it is a small device issue.

1 Like

Hi @Kal_Lam and @wroos ,

I did everything as mentioned in this topic and we have till 2 problems:

1- Desktop web: The map is loaded, but enketo cant record automat location. The user must manually find the point.

In addition to being highly error-prone, this removes the feature of monitoring people’s performance.

2- Mobile: The map does not load at all. Like the image displayed in this message.

My Image:

Could you please guide me?

Hi Everyone,

My issues are about GPS, I did everything as mentioned in this topic and we have till 2 problems:

1- Desktop web: The map is loaded, but enketo cant record automat location. The user must manually find the point.

In addition to being highly error-prone, this removes the feature of monitoring people’s performance.

2- Mobile: The map does not load at all. Like the image displayed in this message.

My Image:

Could you please guide me?

@hoseinnematolahi, does your desktop have a GPS sensor?

Thanks for you response.
this issue there is for iPhone device.