Map issue_ different label for one answer

I am currently facing an issue with the data that appear on my map. When I try to disaggregate the data for one of my questions, it shows 3 different kinds of “no” answers, while the only two answer choices in the questionnaire are “yes” and “no”. I don’t know how to merge the different answers, since these three different “no’s” appear in different colors and distort the final data. I already had a problem with this question, which was solved on this forum, and had to change the label of the answers (the yes appeared “no_1”).
I attach a picture of the problem. What can I do to fix it? Thank you for your help!KoBo Map _ legend.PNG

@CamilleCR, this generally happens when you edit your survey form and then redeploy. Are you able to see this label smoothly with just yes and no under the DATA>Table and under the DATA>Reports? If yes, then this problem should also be solved here.

Ok! I looked in the table and only “yes” and “no” appear, so it works. However in the automated report the problem also appears: with two yes and two no.

Yes, so here is the issue. This happens when you have multiple edits and redeployments.

ok so what can I do to fix it? I can only change that on excel?

I assume, this is a bug at our end. Will reach you back soon.

perfect, thank you

Hello @CamilleCR,
Did you check your form with the Online validator? At least in a previous version of your form you might have had duplicate labels.

1 Like

Hello @wroos
Thank you for your answer. I just tried it and no mistake appears in the column that is concerned by the problem.
But I just saw that this issue with the labels on the legend of the map is happening too with 2 other questions that have multiple answers types. I think that it’s due to a redeployment too, but I would like to be sure because on the automatic report this problem does not happen with the other question (only with the first yes/no that I have mentioned previously). And it does not happen neither on the excel.

You could try to further locate the problem by doing the following:

  • go to the history (versions) of your form
  • clone previous version(s)
  • download the previous version(s) as XLSForm
  • check the previous definition(s) for the choices of the related question(s)…
1 Like

Thank you for your time!
Ok so I did it, as the form has 4 previous versions. Effectively I see that there has been changes in the questions and in the answers. There is some problems with some XML value (for ex a yes was "non_1’) which probably lead to the problem of the labels on the map. Is there a way to merge answers that have been modified because of the redeployment? Or this problem is fully because of the changes made for the redeployement and cannot be solved?