Media files are not being displayed in form

I have a self-hosted server. When I add an image to Settings>Media it does not display in the web form but it displays in the android app. I have followed the instructions in https://support.kobotoolbox.org/media.html and I made sure to redeploy the project after adding the media file, I reuploaded the xlsform, I tried the suggestion here, but I always get a broken image icon
image in the web form.

Like I said it works fine in kobocollect but I primarily need it to work in the web form.

Welcome to the community, @dtrotman! Did you try this on one of the publicly hosted servers (to see if the issue is the same as in your self-hosted server)?

I tried on the public server and was successful. Are there any steps I can take to troubleshoot on my server?

Are you using an older version? I remember one of the old versions had this issue and it was fixed in a later release.

1 Like

How would I determine the version that I’m using?

Go to ee.<your_doman>. Or your custom enketo domain if you set one.
Another way is to open the superuser account and check the commit details on the bottom left corner and compare with the releases on Github kobo-install repo.

1 Like

ee version is 2.8.1 which appears to be current. Kobo-install info is
Branch: HEAD
commit: 08a7a41
Which I can’t seem to find in the repository.

I first installed KoboToolbox on this server around June 2021, Then I upgraded it a few weeks ago though I’m not sure I didn’t mess that up.

This could be the case… Try doing the upgrade again,

  1. Pull the latest stable release of kobo-install
  2. Run python3 run.py --setup, check the settings during installation to see that everything is as required.
1 Like

Ok, I basically reinstalled it from scratch. When I run python3 run.py --version I get

kobo-install Version: 6.6.0 (build 5d8cd0c)

All of the other version numbers are the same. I’m confident that this is the latest version from the master branch. However, I’m still getting the same issue. In case it’s relevant, I’m running on Ubuntu server 20.04 LTS

By web form, you mean the Enketo link of a deployed firm?

1 Like

Yes when viewing the Enketo form, I get a broken image link

I have the same problem, Did you solve this issue?

Sorry for the late reply. I never got this issue resolved, I simply had to rework the form to work without displaying any images

Thank you for replying, I’m doing the same, hope this feature won’t be needed lately.